bool was not a real type in Python <2.3 and had to be marshalled as a
[bootmanager.git] / bootmanager.spec
index 9620ae5..b76ab5a 100644 (file)
@@ -47,8 +47,6 @@ find build.sh source | cpio -p -d -u $RPM_BUILD_ROOT/%{_datadir}/%{name}/
 install -D -m 755 bootmanager.sh $RPM_BUILD_ROOT/var/www/html/boot/bootmanager.sh
 for file in \
     uudecode.gz \
-    alpina-BootLVM.tar.gz \
-    alpina-PartDisks.tar.gz \
     PlanetLab-Bootstrap.tar.bz2 ; do
   install -D -m 644 support-files/$file $RPM_BUILD_ROOT/var/www/html/boot/$file
 done
@@ -61,12 +59,12 @@ rm -rf $RPM_BUILD_ROOT
 # If run under sudo
 if [ -n "$SUDO_USER" ] ; then
     # Allow user to delete the build directory
-    chown -R $SUDO_USER .
+    chown -h -R $SUDO_USER .
     # Some temporary cdroot files like /var/empty/sshd and
     # /usr/bin/sudo get created with non-readable permissions.
     find . -not -perm +0600 -exec chmod u+rw {} \;
     # Allow user to delete the built RPM(s)
-    chown -R $SUDO_USER %{_rpmdir}/%{_arch}
+    chown -h -R $SUDO_USER %{_rpmdir}/%{_arch}
 fi
 
 %post