also return if fsck fails; it's a bad bad idea to try to mount if fsck has just failed.
[bootmanager.git] / bootmanager.spec
index 8d6081e..f97ef29 100644 (file)
@@ -5,7 +5,7 @@
 
 %define name bootmanager
 %define version 4.3
-%define taglevel 3
+%define taglevel 9
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -40,6 +40,7 @@ nodes.
 %setup -q
 
 %build
+gcc -shared -fPIC -Os -o source/libc-opendir-hack.so source/libc-opendir-hack.c
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -73,6 +74,10 @@ Remember to GPG sign /var/www/html/boot/bootmanager.sh with the
 PlanetLab private key.
 EOF
 
+# NOTE: do not run this agent when installed on a myplc.
+chkconfig monitor-runlevelagent off
+chkconfig --del monitor-runlevelagent
+
 %files
 %defattr(-,root,root,-)
 %{_datadir}/%{name}
@@ -80,6 +85,27 @@ EOF
 /var/www/html/boot/uudecode.gz
 
 %changelog
+* Mon Jun 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-9
+- Special handling for "forcedeth" ethernet NIC.
+
+* Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-8
+- include a fix for public pl dealing with old/new boot images and root
+- environments
+
+* Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-7
+- review selection nodefamily at bootstrapfs install-time
+- now based on (1) tags (2) nodefamily and (3) defaults
+- this is required on very old bootcd
+
+* Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-6
+- Use modprobe module to write out /etc/modprobe.conf.
+
+* Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-5
+- minor updates - using the new modprobe module *not* in this tag
+
+* Wed Apr 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-4
+- load device mapper if needed, for centos5-based bootcd variant
+
 * Wed Mar 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-3
 - renumbered 4.3
 - New step StartRunLevelAgent