Im not sure what I'm doing but mef says this is how to make these changes.
[bootstrapfs.git] / bootstrapfs.spec
index abd37f4..86508cf 100644 (file)
@@ -1,11 +1,18 @@
+#
+# $Id$
+#
+%define url $URL$
+
 %define name bootstrapfs
 %define version 0.1
-%define release 0%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+%define taglevel 1
+
+%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
 Vendor: PlanetLab
 Packager: PlanetLab Central <support@planet-lab.org>
-Distribution: PlanetLab 4.2
-URL: http://svn.planet-lab.org/svn/BootStrapFS/
+Distribution: PlanetLab %{plrelease}
+URL: %(echo %{url} | cut -d ' ' -f 2)
 
 Summary: The PlanetLab Bootstrap Filesystems
 Name: %{name}
@@ -30,20 +37,26 @@ BootManager to instantiate a node with a new filesystem.
 %setup -q
 
 %build
-./build.sh
+pushd BootstrapFS
+./build.sh %{pldistro}
+popd BootstrapFS
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
+pushd BootstrapFS
+
 install -D -m 644 PlanetLab-Bootstrap.tar.bz2 \
        $RPM_BUILD_ROOT/var/www/html/boot/PlanetLab-Bootstrap.tar.bz2
 
-for bootstrapfs in $(ls bootstrap-filesystems/*.lst) ; do 
-       NAME=$(basename $bootstrapfs .lst)
-       install -D -m 644 bootstrap-filesystems/PlanetLab-Bootstrap-${NAME}.tar.bz2 \
+for pkgs in $(ls ../build/config.%{pldistro}/bootstrapfs-*.pkgs) ; do 
+    NAME=$(basename $pkgs .pkgs | sed -e s,bootstrapfs-,,)
+    install -D -m 644 %{pldistro}-filesystems/PlanetLab-Bootstrap-${NAME}.tar.bz2 \
                $RPM_BUILD_ROOT/var/www/html/boot/PlanetLab-Bootstrap-${NAME}.tar.bz2
 done
 
+popd
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -63,7 +76,6 @@ fi
 
 %files
 %defattr(-,root,root,-)
-%{_datadir}/%{name}
 /var/www/html/boot/PlanetLab-Bootstrap*.tar.bz2
 
 %changelog