postinstall for signing pkgs - noderepo requires myplc - using Provides: on the myplc...
[bootstrapfs.git] / bootstrapfs.spec
index abd37f4..a43e01e 100644 (file)
@@ -1,11 +1,18 @@
+#
+# $Id$
+#
+%define url $URL$
+
 %define name bootstrapfs
 %define version 0.1
-%define release 0%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+%define taglevel 2
+
+%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
 Vendor: PlanetLab
 Packager: PlanetLab Central <support@planet-lab.org>
-Distribution: PlanetLab 4.2
-URL: http://svn.planet-lab.org/svn/BootStrapFS/
+Distribution: PlanetLab %{plrelease}
+URL: %(echo %{url} | cut -d ' ' -f 2)
 
 Summary: The PlanetLab Bootstrap Filesystems
 Name: %{name}
@@ -30,20 +37,26 @@ BootManager to instantiate a node with a new filesystem.
 %setup -q
 
 %build
-./build.sh
+pushd BootstrapFS
+./build.sh %{pldistro}
+popd BootstrapFS
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
+pushd BootstrapFS
+
 install -D -m 644 PlanetLab-Bootstrap.tar.bz2 \
        $RPM_BUILD_ROOT/var/www/html/boot/PlanetLab-Bootstrap.tar.bz2
 
-for bootstrapfs in $(ls bootstrap-filesystems/*.lst) ; do 
-       NAME=$(basename $bootstrapfs .lst)
-       install -D -m 644 bootstrap-filesystems/PlanetLab-Bootstrap-${NAME}.tar.bz2 \
+for pkgs in $(ls ../build/config.%{pldistro}/bootstrapfs-*.pkgs) ; do 
+    NAME=$(basename $pkgs .pkgs | sed -e s,bootstrapfs-,,)
+    install -D -m 644 %{pldistro}-filesystems/PlanetLab-Bootstrap-${NAME}.tar.bz2 \
                $RPM_BUILD_ROOT/var/www/html/boot/PlanetLab-Bootstrap-${NAME}.tar.bz2
 done
 
+popd
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -63,9 +76,13 @@ fi
 
 %files
 %defattr(-,root,root,-)
-%{_datadir}/%{name}
 /var/www/html/boot/PlanetLab-Bootstrap*.tar.bz2
 
 %changelog
+* Fri Jan 18 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-0.1-1 bootstrapfs-0.1-2
+- search more carefully for alternate pkgs files
+- handling of sysconfig/crontab and creation of site_admin reviewed
+- (this tag is set with module-tag.py)
+
 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
 - Initial build.