just whole-sale copy the monitor module into python site-arch.
[monitor.git] / monitor-server.spec
index de00fa1..0576459 100644 (file)
@@ -74,9 +74,10 @@ echo " * TODO: Setting up Monitor account in local MyPLC"
 mkdir -p $RPM_BUILD_ROOT/%{python_sitearch}/monitor
 install -d -D -m 755 monitor $RPM_BUILD_ROOT/%{python_sitearch}/monitor
 # TODO: need a much better way to do this.
-for file in __init__.py database.py config.py ; do 
-       install -D -m 644 monitor/$file $RPM_BUILD_ROOT/%{python_sitearch}/monitor/$file
-done
+rsync -a monitor/ $RPM_BUILD_ROOT/%{python_sitearch}/monitor/
+#for file in __init__.py database.py config.py ; do 
+#      install -D -m 644 monitor/$file $RPM_BUILD_ROOT/%{python_sitearch}/monitor/$file
+#done
 install -D -m 755 threadpool.py $RPM_BUILD_ROOT/%{python_sitearch}/threadpool.py
 
 touch $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php