just whole-sale copy the monitor module into python site-arch.
[monitor.git] / monitor-server.spec
index d3b326c..0576459 100644 (file)
@@ -5,8 +5,8 @@
 %define url $URL: svn+ssh://svn.planet-lab.org/svn/Monitor/trunk/Monitor-server.spec $
 
 %define name monitor-server
-%define version 1.0
-%define taglevel 8
+%define version 1.1
+%define taglevel 0
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 %global python_sitearch        %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
@@ -74,9 +74,10 @@ echo " * TODO: Setting up Monitor account in local MyPLC"
 mkdir -p $RPM_BUILD_ROOT/%{python_sitearch}/monitor
 install -d -D -m 755 monitor $RPM_BUILD_ROOT/%{python_sitearch}/monitor
 # TODO: need a much better way to do this.
-for file in __init__.py database.py config.py ; do 
-       install -D -m 644 monitor/$file $RPM_BUILD_ROOT/%{python_sitearch}/monitor/$file
-done
+rsync -a monitor/ $RPM_BUILD_ROOT/%{python_sitearch}/monitor/
+#for file in __init__.py database.py config.py ; do 
+#      install -D -m 644 monitor/$file $RPM_BUILD_ROOT/%{python_sitearch}/monitor/$file
+#done
 install -D -m 755 threadpool.py $RPM_BUILD_ROOT/%{python_sitearch}/threadpool.py
 
 touch $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
@@ -128,3 +129,5 @@ echo "Post processing"
 
 * Wed Jul 30 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-server-1.0-5
 - initial creation of server-side package
+
+%define module_current_branch 1.0