Try to build the AMT command. I expect the /tmp fs to be too small.
[monitor.git] / monitor-server.spec
index a953e86..0975831 100644 (file)
@@ -6,7 +6,7 @@
 
 %define name monitor-server
 %define version 1.0
-%define taglevel 5
+%define taglevel 6
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -29,6 +29,8 @@ Requires: coreutils
 Requires: openssh-clients
 Requires: PLCWWW >= 4.2
 Requires: BootCD >= 4.2
+Requires: MySQL-python
+Requires: rt3 == 3.4.1
 
 %description
 Scripts for polling PLC, the node, and PCU status.  Also a collection of
@@ -39,13 +41,16 @@ command-line utilities for querying the status database.
 
 %build
 # TODO: note that we should build the cmdamt/ with g++
-echo "There is no build stage.  Simply copy files."
+cd cmdamt
+make
+cd ..
 
 %install
 
 rm -rf $RPM_BUILD_ROOT
 mkdir -p $RPM_BUILD_ROOT/usr/share/%{name}
 mkdir -p $RPM_BUILD_ROOT/var/lib/%{name}
+mkdir -p $RPM_BUILD_ROOT/var/lib/%{name}/archive-pdb
 mkdir -p $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/
 
 echo " * Installing core scripts"
@@ -55,9 +60,10 @@ rsync -a --exclude www --exclude archive-pdb --exclude .svn --exclude CVS \
 echo " * Installing web pages"
 rsync -a www/ $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/
 
-echo " * TODO: Installing cron job for automated polling"
-install -D -m 755 %{name}.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/%{name}
+echo " * Installing cron job for automated polling"
+install -D -m 755 %{name}.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/%{name}.cron
 echo " * TODO: Setting up Monitor account in local MyPLC"
+# TODO: 
 
 cp $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig-default.py $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig.py
 
@@ -70,7 +76,7 @@ rm -rf $RPM_BUILD_ROOT
 /usr/share/%{name}
 /var/lib/%{name}
 /var/www/cgi-bin/monitor
-%{_sysconfdir}/cron.d/%{name}
+%{_sysconfdir}/cron.d/%{name}.cron
 
 %post
 echo "Post processing"
@@ -80,10 +86,15 @@ echo "Post processing"
 # TODO: create monitorconfig.php using phpconfig.py 
 # TODO: create symlink in /var/lib/monitor-server for chroot environments
 # TODO: update the content of automate_pl03.sh 
+# TODO: Use the installed version of bootcd to create custom boot images. ( or, use the api now).
 
 #chkconfig --add monitor-server
 #chkconfig monitor-server on
 
 %changelog
+* Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-6
+- This is a major tag of every thing.  probably needs a very different release
+- number.
+
 * Wed Jul 30 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-server-1.0-5
 - initial creation of server-side package