Tagging module nodeconfig - nodeconfig-4.2-12
[nodeconfig.git] / nodeconfig.spec
index c77b6c7..3575c7e 100644 (file)
@@ -1,11 +1,11 @@
 #
-# $Id: PLCWWW.spec 7881 2008-01-22 14:45:22Z thierry $
+# $Id$
 #
-%define url $URL: svn+ssh://thierry@svn.planet-lab.org/svn/WWW/trunk/PLCWWW.spec $
+%define url $URL$
 
 %define name nodeconfig
 %define version 4.2
-%define taglevel 3
+%define taglevel 12
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -40,8 +40,11 @@ reasons these scripts get installed in /var/www/html/PlanetLabConf.
 %setup -q
 
 %build
-echo "There is no build stage for this component."
-echo "All files just need to be installed as is from the codebase."
+EXCLUDE="exclude=kernel* util-vserver* iptables iproute"
+for filein in $(find . -name '*.in') ; do
+    file=$(echo $filein | sed -e "s,\.in$,,")
+    sed -e "s,@EXCLUDE@,$EXCLUDE,g" $filein > $file
+done
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -52,7 +55,7 @@ for dir in boot PlanetLabConf PLCAPI ; do
     mkdir -p $RPM_BUILD_ROOT/var/www/html/$dir
 done
 # let's be conservative and exclude codebase files, though there should not be any
-rsync -a --exclude \*.spec --exclude .svn --exclude CVS ./ $RPM_BUILD_ROOT/var/www/html/
+rsync -a --exclude \*.spec --exclude .svn --exclude \*.in ./ $RPM_BUILD_ROOT/var/www/html/
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -64,6 +67,37 @@ rm -rf $RPM_BUILD_ROOT
 /var/www/html/PLCAPI
 
 %changelog
+* Mon Sep 15 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-4.2-12
+- yum config for nodes needs to mention the additional 'newkey' repository
+
+* Mon Aug 04 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - nodeconfig-4.2-11
+- PlanetFlow/codemux fix
+- Used "./module-tag -b 4.2 nodeconfig:4.2".
+
+* Fri Jul 25 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - nodeconfig-4.2-10
+- syntax error. Fixed.
+
+* Fri Jul 25 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - nodeconfig-4.2-9
+- Updated ntp conf files.
+- I2 iptables for nodes on I2.
+
+* Thu Jul 24 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - nodeconfig-4.2-8
+- iptables superceded by svn/iptables/planetlab-config
+
+* Sat Jul 19 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-4.2-7
+- svn keyword expansion fixed, no functional change
+
+* Fri Jul 04 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-4.2-6
+- yum config on nodes improved -- see https://svn.planet-lab.org/ticket/342
+
+* Wed Jun 25 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-4.2-5
+- yum.conf.php handles nodegroups and slicefamily
+- svn keywords fixed
+
+* Tue Apr 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-4.2-4
+- keys.php know about monitor
+- new sudoers.php script
+
 * Thu Apr 03 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - nodeconfig-4.2-2 nodeconfig-4.2-3
 - Added support for centralized PlanetFlow.