oops - committed to deep in tree - should have been part of 12131
[nodeconfig.git] / nodeconfig.spec
index 93e1d7d..5ef96d5 100644 (file)
@@ -5,7 +5,7 @@
 
 %define name nodeconfig
 %define version 4.2
-%define taglevel 5
+%define taglevel 13
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -27,7 +27,8 @@ URL: %(echo %{url} | cut -d ' ' -f 2)
 # We use set everywhere
 Requires: php >= 5.0
 Requires: PLCAPI >= 4.0
-
+# need the apache user at install-time 
+Requires: httpd  
 %description
 
 The nodeconfig package provides various php scripts that are used to
@@ -40,7 +41,7 @@ reasons these scripts get installed in /var/www/html/PlanetLabConf.
 %setup -q
 
 %build
-EXCLUDE="exclude=kernel* iptables iproute util-vserver*"
+EXCLUDE="exclude=kernel* util-vserver* iptables iproute"
 for filein in $(find . -name '*.in') ; do
     file=$(echo $filein | sed -e "s,\.in$,,")
     sed -e "s,@EXCLUDE@,$EXCLUDE,g" $filein > $file
@@ -57,6 +58,11 @@ done
 # let's be conservative and exclude codebase files, though there should not be any
 rsync -a --exclude \*.spec --exclude .svn --exclude \*.in ./ $RPM_BUILD_ROOT/var/www/html/
 
+# the boot manager upload area
+mkdir -p /var/log/bm
+chown apache:apache /var/log/bm
+chmod 700 /var/log/bm
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -67,6 +73,32 @@ rm -rf $RPM_BUILD_ROOT
 /var/www/html/PLCAPI
 
 %changelog
+* Fri Sep 19 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - nodeconfig-4.2-13
+- This configuration file has a single line addition to the standard configuration and it's based on state maintained in the DB.  This has been deprecated in favor of maintaining it in NM.  The standard configuration is in the iptables module and the nodegroup specific addition is created when the ipset is created by NM.
+
+* Mon Sep 15 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-4.2-12
+- yum config for nodes needs to mention the additional 'newkey' repository
+
+* Mon Aug 04 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - nodeconfig-4.2-11
+- PlanetFlow/codemux fix
+- Used "./module-tag -b 4.2 nodeconfig:4.2".
+
+* Fri Jul 25 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - nodeconfig-4.2-10
+- syntax error. Fixed.
+
+* Fri Jul 25 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - nodeconfig-4.2-9
+- Updated ntp conf files.
+- I2 iptables for nodes on I2.
+
+* Thu Jul 24 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - nodeconfig-4.2-8
+- iptables superceded by svn/iptables/planetlab-config
+
+* Sat Jul 19 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-4.2-7
+- svn keyword expansion fixed, no functional change
+
+* Fri Jul 04 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-4.2-6
+- yum config on nodes improved -- see https://svn.planet-lab.org/ticket/342
+
 * Wed Jun 25 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-4.2-5
 - yum.conf.php handles nodegroups and slicefamily
 - svn keywords fixed