Tagging module nodeconfig - nodeconfig-4.2-6
[nodeconfig.git] / nodeconfig.spec
index 7c0542a..6032faa 100644 (file)
@@ -5,7 +5,7 @@
 
 %define name nodeconfig
 %define version 4.2
-%define taglevel 4
+%define taglevel 6
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -40,8 +40,11 @@ reasons these scripts get installed in /var/www/html/PlanetLabConf.
 %setup -q
 
 %build
-echo "There is no build stage for this component."
-echo "All files just need to be installed as is from the codebase."
+EXCLUDE="exclude=kernel* util-vserver* iptables iproute"
+for filein in $(find . -name '*.in') ; do
+    file=$(echo $filein | sed -e "s,\.in$,,")
+    sed -e "s,@EXCLUDE@,$EXCLUDE,g" $filein > $file
+done
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -52,7 +55,7 @@ for dir in boot PlanetLabConf PLCAPI ; do
     mkdir -p $RPM_BUILD_ROOT/var/www/html/$dir
 done
 # let's be conservative and exclude codebase files, though there should not be any
-rsync -a --exclude \*.spec --exclude .svn --exclude CVS ./ $RPM_BUILD_ROOT/var/www/html/
+rsync -a --exclude \*.spec --exclude .svn --exclude \*.in ./ $RPM_BUILD_ROOT/var/www/html/
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -64,6 +67,13 @@ rm -rf $RPM_BUILD_ROOT
 /var/www/html/PLCAPI
 
 %changelog
+* Fri Jul 04 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-4.2-6
+- yum config on nodes improved -- see https://svn.planet-lab.org/ticket/342
+
+* Wed Jun 25 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-4.2-5
+- yum.conf.php handles nodegroups and slicefamily
+- svn keywords fixed
+
 * Tue Apr 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-4.2-4
 - keys.php know about monitor
 - new sudoers.php script