install nodemanager with systemd unit files instead of initscripts
[nodemanager.git] / nodemanager-lib.spec
index 1ea073b..90a2dc6 100644 (file)
@@ -2,10 +2,9 @@
 
 %define name nodemanager-lib
 %define version 5.2
-%define taglevel 3
+%define taglevel 9
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
-%global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
 
 Summary: PlanetLab Node Manager Library
 Name: %{name}
@@ -46,18 +45,24 @@ local operations on slices.
 nodemanager-lib only provides a skeleton and needs as a companion
 either nodemanager-vs or nodemanager-lxc
 
+# use initscripts or systemd unit files to start installed services
+%if "%{distro}" == "Fedora" && %{distrorelease} >= 18
+%define make_options=WITH_SYSTEMD=true
+%else
+%define make_options=WITH_INIT=true
+%endif
+
 %prep
 %setup -q
 
 %build
 # make manages the C and Python stuff
-%{__make} %{?_smp_mflags} lib
+%{__make} %{?_smp_mflags} %{make_options} lib 
 
 %install
 # make manages the C and Python stuff
 rm -rf $RPM_BUILD_ROOT
-%{__make} %{?_smp_mflags} install-lib DESTDIR="$RPM_BUILD_ROOT"
-PYTHON_SITEARCH=`python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)'`
+%{__make} %{?_smp_mflags} %{make_options} install-lib DESTDIR="$RPM_BUILD_ROOT"
 
 # install the sliver initscript (that triggers the slice initscript if any)
 mkdir -p $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
@@ -132,6 +137,39 @@ rm -rf $RPM_BUILD_ROOT
 /bin/sshsh
 
 %changelog
+* Wed Dec 11 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-9
+- fixes in hostmap, and in interfaces
+- new vsys_sysctl
+- privatebridge now comes with nodemanager-lib
+
+* Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-8
+- omf plugin does not block any longer when running trigger script
+- log goes into sliver's /var/log instead
+
+* Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-7
+- new install-scripts target in Makefile
+- conf_files and fuse-pl initscripts chmod'ed +x
+- omf_resctl config template tweaked to use _slicename_%_hostname_
+
+* Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-6
+- make sure to create /etc/planetlab/virt so others can read that
+- expose get_node_virt() and command_in_slice()
+- refined omf_resctl plugin (fetches trigger, and calls it on expire change)
+- user's .profile now has right owner
+- other tweaks in lxc slivers
+
+* Wed Jul 03 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-5
+- lxc slice creation: slice user was created with unknown gid - fixed
+- lxc slice creation: .profile for root and user - fixed
+
+* Sat Jun 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-4
+- fix umounting of ssh directory when deleting omf-friendly slivers
+- support for writing cgroups in subsystems other than cpuset
+- add xid to template match
+- finer-grained split between -lib -vs and -lxc
+- first roughly complete omf_resctl for omfv6
+- minor fix for when getslivers does not have minexemptrate
+
 * Fri May 24 2013 Andy Bavier <acb@cs.princeton.edu> - nodemanager-5.2-3
 - Fix path, machine arch in slivers
 
@@ -469,12 +507,14 @@ rm -rf $RPM_BUILD_ROOT
 - Codemux supports multiple hosts mapping to single slice
 - Fixed bug in delegation support where tickets delivered weren't
   being passed to sm.deliver_ticket().
+
 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
 - Codemux now configured via slice attribute (host,port)
 - Support for multiple vserver reference images (including different archs)
 - Mom BW emails are sent to list defined by MyPLC's config
 - Sirius BW loans honored correctly.  Fixed.
 - BW totals preserved for dynamic slices so as not to game the system.
+
 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
 - Configures vsys via vsys slice attribute {name: vsys, value: script}
 - CPU reservations are now calculated via percentages instead of shares