add missing import subprocess
[nodemanager.git] / nodemanager-lxc.spec
index 2fb7c8e..db512bc 100644 (file)
@@ -5,7 +5,7 @@
 
 %define name nodemanager-lxc
 %define version 5.2
-%define taglevel 6
+%define taglevel 13
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -23,13 +23,16 @@ Packager: PlanetLab Central <support@planet-lab.org>
 Distribution: PlanetLab %{plrelease}
 URL: %{SCMURL}
 
+# for nodeupdate 
+Provides: nodemanager
+
 # we use libvirt
 Requires: libvirt
 Requires: libvirt-python
 # cgroups.py needs this
 Requires: python-inotify
 # the common package for nodemanager
-Requires: nodemanager-lib
+Requires: nodemanager-lib = %{version}
 # the lxc-specific tools for using slice images
 Requires: lxc-sliceimage
 Requires: openvswitch
@@ -58,6 +61,43 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/NodeManager/
 
 %changelog
+* Mon Apr 28 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-13
+- improve network management in slices
+- _has_systemctl was not declared as global - vsys was failing to restart
+
+* Fri Apr 04 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-12
+- this tag for the first time passes the full range of tests on fedora20
+- robustified slice teardown wrt vsys
+- Scott's fix for repairing veth devs
+- removed sshsh
+- tools.has_systemctl
+
+* Tue Mar 25 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-11
+- ship /etc/sysconfig/nodemanager
+- trash sshsh
+
+* Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-10
+- comes with systemd native unit files on >= f18
+- user-provided initscript gets started through systemd in slivers >= f18
+- smarter to locate cgroups for various versions of libvirt
+- nicer log format - and log program termination
+- tweaks in codemux plugin
+- bug fixes in libvirt driver, esp. for finding out if domain is running
+
+* Wed Dec 11 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-9
+- fixes in hostmap, and in interfaces
+- new vsys_sysctl
+- privatebridge now comes with nodemanager-lib
+
+* Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-8
+- omf plugin does not block any longer when running trigger script
+- log goes into sliver's /var/log instead
+
+* Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-7
+- new install-scripts target in Makefile
+- conf_files and fuse-pl initscripts chmod'ed +x
+- omf_resctl config template tweaked to use _slicename_%_hostname_
+
 * Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-6
 - make sure to create /etc/planetlab/virt so others can read that
 - expose get_node_virt() and command_in_slice()