- don't install alpha RPMs in the vserver-reference image
[vserver-reference.git] / vserver-reference.spec
index 0459f65..9082a80 100644 (file)
@@ -20,6 +20,8 @@ Requires: util-vserver
 AutoReqProv: no
 BuildRequires: e2fsprogs, yum
 
+%define debug_package %{nil}
+
 %description
 This package creates the virtual server (VServer) reference image used
 as the installation base for new PlanetLab slivers.
@@ -40,6 +42,9 @@ fi
 %build
 
 %install
+# Running as root
+export PATH="$PATH:/sbin:/usr/sbin"
+
 # Clean up
 if grep -q %{installroot}/proc /proc/mounts ; then
     umount %{installroot}/proc
@@ -108,7 +113,7 @@ rpm --root %{installroot} --initdb
 # XXX Get yum.conf from PlanetLabConf
 
 # Install RPMs in reference image
-yum \
+yum -c ./yum.conf \
 %{?sslcertdir:--sslcertdir=%{sslcertdir}} \
 --installroot=%{installroot} \
 -y groupinstall VServer
@@ -131,6 +136,9 @@ if grep -q %{installroot}/dev/pts /proc/mounts ; then
 fi
 
 %clean
+# Running as root
+export PATH="$PATH:/sbin:/usr/sbin"
+
 # Clean up
 if grep -q %{installroot}/proc /proc/mounts ; then
     umount %{installroot}/proc