- don't install alpha RPMs in the vserver-reference image
[sliceimage.git] / vserver-reference.spec
index ea0c859..9082a80 100644 (file)
@@ -20,6 +20,8 @@ Requires: util-vserver
 AutoReqProv: no
 BuildRequires: e2fsprogs, yum
 
+%define debug_package %{nil}
+
 %description
 This package creates the virtual server (VServer) reference image used
 as the installation base for new PlanetLab slivers.
@@ -40,6 +42,9 @@ fi
 %build
 
 %install
+# Running as root
+export PATH="$PATH:/sbin:/usr/sbin"
+
 # Clean up
 if grep -q %{installroot}/proc /proc/mounts ; then
     umount %{installroot}/proc
@@ -131,6 +136,9 @@ if grep -q %{installroot}/dev/pts /proc/mounts ; then
 fi
 
 %clean
+# Running as root
+export PATH="$PATH:/sbin:/usr/sbin"
+
 # Clean up
 if grep -q %{installroot}/proc /proc/mounts ; then
     umount %{installroot}/proc