- RPM is too $#%@! stupid to understand bash here documents and tries
[vserver-reference.git] / vserver-reference.spec
index ff6fd93..f3272bf 100644 (file)
@@ -102,10 +102,11 @@ EOF
 
 # Prevent all locales from being installed in reference image
 mkdir -p %{installroot}/etc/rpm
-cat > %{installroot}/etc/rpm/macros <<EOF
-%_install_langs en_US:en
-%_excludedocs 1
-EOF
+(
+echo "%_install_langs en_US:en"
+echo "%_excludedocs 1"
+echo "%__file_context_path /dev/null"
+) > %{installroot}/etc/rpm/macros
 
 # Initialize RPM database in reference image
 mkdir -p %{installroot}/var/lib/rpm
@@ -119,6 +120,9 @@ yum -c ./yum.conf \
 --installroot=%{installroot} \
 -y groupinstall VServer
 
+# Freshen any new RPMs
+find %{_topdir}/RPMS -type f | xargs rpm --root %{installroot} -F
+
 # Clean up /dev in reference image
 MAKEDEV