- set __file_context_path to /dev/null avoid stupid SELinux warning
[vserver-reference.git] / vserver-reference.spec
index ff6fd93..f4f7511 100644 (file)
@@ -105,6 +105,7 @@ mkdir -p %{installroot}/etc/rpm
 cat > %{installroot}/etc/rpm/macros <<EOF
 %_install_langs en_US:en
 %_excludedocs 1
+%__file_context_path /dev/null
 EOF
 
 # Initialize RPM database in reference image
@@ -119,6 +120,9 @@ yum -c ./yum.conf \
 --installroot=%{installroot} \
 -y groupinstall VServer
 
+# Freshen any new RPMs
+find %{_topdir}/RPMS -type f | xargs rpm --root %{installroot} -F
+
 # Clean up /dev in reference image
 MAKEDEV