prune to avoid conflicts
[autoconf.git] / autoconf.spec
1 %define name autoconf
2 %define version 2.69
3 %define taglevel 1
4
5 %global __debug_package 0
6
7 %define release %{taglevel}
8
9 Vendor: OneLab
10 Packager: OneLab <support@planet-lab.eu>
11 Distribution: PlanetLab %{plrelease}
12 URL: %{SCMURL}
13
14 Summary: autoconf rebuilt for sliver-openvswitch on f12
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 License: GPL
19 Group: System Environment/Development
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
21 Source0: autoconf-%{version}.tar.gz
22
23 %description
24 autoconf automake
25
26 %prep 
27 %setup -q
28
29 %build
30 ./configure --prefix=/usr
31 make
32
33 %install
34 make install DESTDIR=$RPM_BUILD_ROOT
35 # this conflicts with other fedora packages
36 for prune in /usr/share/info ; do
37     rm -rf $RPM_BUILD_ROOT/$prune
38 done
39
40 %clean
41 rm -rf $RPM_BUILD_ROOT
42
43 %files
44 /usr
45
46 %post
47
48 %postun
49
50 %changelog