Setting tag bbn_80211-3.2.2-4
[bbn_80211.git] / bbn_80211.spec
1 # SPEC file for bbn_80211
2 #
3 #
4 # Original source from https://128.2.212.19/wiki/BBN80211
5 # Ben Maher Yahmed fix to let compile it with gnuradio 3.2.2 and USRP2
6 # Version 3.2.2 is the same than for gnuradio
7 # File: bbn_80211.tar.gz stored locally at:
8 #
9 %define name bbn_80211
10 %define version 3.2.2
11 %define release 4
12 %define actual_name %{name}-%{version}
13
14 # for module-tools
15 %define module_taglevel_varname release
16
17 Name: %{name}
18 Summary: Very basic 802.11 transceiver code from BBN
19 Version: %{version}
20 Release: %{release}
21 License: GPLv2
22 URL: https://128.2.212.19/wiki/BBN80211
23 Group: BBN
24 Source: %{actual_name}.tar.gz
25 BuildRoot: %{_tmppath}/%{actual_name}
26
27
28 BuildRequires:  swig gnuradio gnuradio-devel
29
30 Requires: swig gnuradio boost
31
32 %description
33 Basic 802.11 transmitter and receiver, which is able 
34 to decode low rate 802.11 packets from standard NICs 
35 over the air reliably at 1Mbps and partially at 2Mbps. 
36
37 %prep
38 %setup -q -n %{actual_name}
39 # patch bbn_tap.cc that lacks an include (critical on f12)
40 sed -i '
41 /#include <stdexcept>/ a\
42 #include <stdio.h>
43 ' gr-bbn/src/bbn/bbn_tap.cc 
44
45 %build
46 #PKG_CONFIG_PATH="/usr/lib/pkgconfig"
47 #export PKG_CONFIG_PATH
48 cd gr-bbn
49 ./configure --prefix=/usr 
50 make
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 mkdir $RPM_BUILD_ROOT
55 mkdir -p $RPM_BUILD_ROOT%{_datadir}/%{actual_name}
56 cp -pru gr-bbn $RPM_BUILD_ROOT%{_datadir}/%{actual_name}
57 cd gr-bbn
58 make DESTDIR=$RPM_BUILD_ROOT install
59
60
61 %post
62 ldconfig
63
64 %postun
65 ldconfig
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70
71 %files 
72 %defattr(-,root,root,-)
73 %{_bindir}/*
74 %{_includedir}/gnuradio/*
75 /usr/lib*/python*/site-packages/
76 %dir %{_datadir}/%{actual_name}
77 %{_datadir}/%{actual_name}/*
78
79
80
81
82
83 %changelog -n bbn_80211
84 * Thu Feb 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bbn_80211-3.2.2-4
85 - bugfix for packaging on 64bits
86
87 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bbn_80211-3.2.2-3
88 - add explicit dep to boost
89
90 * Wed Jan 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bbn_80211-3.2.2-2
91 - rework for f12
92
93 * Mon Oct 5 2009 Thierry Turletti <turletti@sophia.inria.fr> 3.2.2-1.1
94 - fixed errors with rpmlint
95
96 * Mon Oct 5 2009 Thierry Turletti <turletti@sophia.inria.fr> 3.2.2-1.0
97 - first version
98
99
100
101