password generation utility was still python2
[bootcd.git] / bootcd.spec
1 #
2 %define nodefamily %{pldistro}-%{distroname}-%{_arch}
3
4 %define name bootcd-%{nodefamily}
5 %define version 6.0
6 %define taglevel 0
7
8 # pldistro already in the rpm name
9 %define release %{taglevel}%{?date:.%{date}}
10
11 # structure - this results in 2 packages
12 # bootcd-initscripts - has the plc.d/ scripts
13 # bootcd-<nodefamily> - has the actual stuff for a given nodefamily
14
15 Vendor: PlanetLab
16 Packager: PlanetLab Central <support@planet-lab.org>
17 Distribution: PlanetLab %{plrelease}
18 URL: %{SCMURL}
19
20 Summary: Boot CD material for %{nodefamily}
21 Name: %{name}
22 Version: %{version}
23 Release: %{release}
24 License: BSD
25 Group: System Environment/Base
26 Source0: %{name}-%{version}.tar.gz
27 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
28 # other archs must be able to install this
29 BuildArch: noarch
30
31 Requires: dosfstools, genisoimage, gzip, mtools, syslinux
32 # yumdownloader is needed in bootcd-kernel
33 Requires: yum-utils
34 # mkdiskimage is used for USB-partitioned mode
35 # but it now comes in a separate rpm
36 %if "%{distro}" == "Fedora" && %{distrorelease} >= 14
37 Requires: syslinux-perl
38 %endif
39
40 Requires: pyplnet
41
42 # 5.0 now has 3-fold nodefamily
43 %define obsolete_nodefamily %{pldistro}-%{_arch}
44 Obsoletes: bootcd-%{obsolete_nodefamily}
45
46 AutoReqProv: no
47 %define debug_package %{nil}
48
49 %description
50 The Boot CD securely boots PlanetLab nodes into an immutable
51 environment. This package is designed to be installed on a MyPLC
52 installation and provide the basics for the PLC to able to compute
53 BootCDs for its attached nodes. 
54 See http://svn.planet-lab.org/wiki/NodeFamily
55
56
57 %package -n bootcd-initscripts
58 Summary: initscripts for the MyPLC installation
59 Group: System Environment/Base
60 %description -n bootcd-initscripts
61 This package contains the init scripts that get fired when the PLC is
62 restarted.
63
64 ### avoid having yum complain about updates, as stuff is moving around
65 # plc.d/bootcd*
66 Conflicts: MyPLC <= 4.3
67
68 %prep
69 %setup -q
70
71 %build
72 [ -d bootcd ] || ln -s BootCD bootcd
73
74 pushd bootcd
75
76 # Build the reference image - pass 3-fold version number to go in version.txt
77 ./prep.sh %{pldistro} %{nodefamily} %{version}
78
79 popd
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83
84 pushd bootcd
85
86 # Install the reference image and build scripts
87 install -d -m 755 $RPM_BUILD_ROOT/%{_datadir}/%{name}
88 install -m 755 build.sh $RPM_BUILD_ROOT/%{_datadir}/%{name}/
89 install -m 755 kvariant.sh $RPM_BUILD_ROOT/%{_datadir}/%{name}/
90 tar cpf - \
91     build/isofs/bootcd.img \
92     build/isofs/kernel \
93     build/passwd \
94     build/version.txt \
95     build/nodefamily \
96     configurations | \
97     tar -C $RPM_BUILD_ROOT/%{_datadir}/%{name}/ -xpf -
98
99 for script in bootcd bootcd-kernel; do 
100     install -D -m 755 plc.d/$script $RPM_BUILD_ROOT/etc/plc.d/$script
101 done
102
103 popd
104     
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %files
109 %defattr(-,root,root,-)
110 %{_datadir}/%{name}
111
112 %files -n bootcd-initscripts
113 %defattr(-,root,root,-)
114 /etc/plc.d
115
116 %changelog
117 * Mon Jan 07 2019 Thierry <Parmentelat> - bootcd-6.0-0
118 - requires 'genisoimage' rather than deprecated 'mkisofs'
119 - set kernel arg `net.ifnames=0` in addition to `biosdevname=0`
120 - does not use ifconfig, instead use ip and nm-ifup, or look up /sys/class/net
121 - slightly review the contents of forensics messages
122
123 * Sun Jul 10 2016 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.4-1
124 - use 8.8.8.8 s a DNS server if nothing else works
125 - more consistent and verbose forensics system
126
127 * Tue Dec 08 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.3-3
128 - patch for f23 as of dec. 2015 where kernel and initrd show up in
129 - a new location under /boot
130
131 * Fri Nov 13 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.3-2
132 - various fixes for resolv.conf
133
134 * Fri Jun 26 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.3-1
135 - use TLSv1 instead of SSLv3
136 - on systemd distros, do not try to replace the whole boot sequence
137 - as older bootCDs did; pl_boot is now just one more service, not the single
138 - service to run; this solves f21 bootCDs not starting up properly
139
140 * Fri Apr 24 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.2-6
141 - remove default kargs systemd.log_target=console console=ttyS0,115200
142 - simpler bootcd layout (no memdisk nor isolinux-debug.bin)
143 - keep track of actual kargs in log file for build.sh
144
145 * Fri Apr 03 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.2-5
146 - changes for fedora 21 and its new release of syslinux
147
148 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.2-4
149 - no change, only some internal comments were changed
150
151 * Wed Jun 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.2-3
152 - attempt to make node take off more reliable with pl_wrapper
153
154 * Wed Apr 24 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.2-2
155 - fix version number as it shows up in version.txt (was empty)
156
157 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.2-1
158 - turn off systemd traces at boot-time
159
160 * Tue Feb 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.1-5
161 - fix console on tty2: this broke the build on fedora14
162 - even though f14 doesn't use systemd by defaults there is /etc/systemd in there
163
164 * Fri Feb 22 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.1-4
165 - turn on getty/console on tty2
166
167 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.1-3
168 - reviewed for systemd & f18
169
170 * Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.1-2
171 - turn off selinux, turns out needed with some combinations like lxc/f14
172
173 * Wed Apr 11 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.1-1
174 - compatible with pre- and post- f16
175 - add systemd friendlyness to bootcd
176 - also add biosdevname=0 tp kernel args so ethernet devices are still named in eth<x>
177
178 * Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.0-11
179 - add requires: to syslinux-perl on fedora14
180
181 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.0-10
182 - blacklisted mdules
183 - requires yum-utils for yumdownloader in bootcd-kernel
184
185 * Mon Feb 21 2011 S.Çağlar Onur <caglar@verivue.com> - bootcd-5.0-9
186 - Handle /dev/rtc name change for newer kernels
187
188 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - bootcd-5.0-8
189 - Revert hacky solution for 2.6.32 based kernels as they are no longer required
190
191 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.0-7
192 - changes for booting off fedora14
193 - displays some sanity checks in case bm can's get downloaded
194 - virtio devices in /dev/vd* also considered
195 - start service rsyslog if found
196 - hack for kernel-firmware with 2.6.32
197 - use $() instead of ``
198
199 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.0-6
200 - use /usr/lib/syslinux/mkdiskimage or installed mkdiskimage
201
202 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.0-5
203 - remove remainging reference to planet-lab.org
204
205 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootCD-5.0-4
206 - module name changes
207
208 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-5.0-3
209 - nicer initscript now uses 'action' from /etc/init.d/functions
210
211 * Tue Apr 20 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootCD-5.0-2
212 - obsolete old bootcd versions
213
214 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-5.0-1
215 - First working version of 5.0:
216 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
217 - nodefamily is 3-fold with pldistro-fcdistro-arch
218 - new module bootcd-inistscripts
219
220 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-17
221 - support for fedora 12
222
223 * Sun Dec 27 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-16
224 - fix build on fedora12
225
226 * Fri Sep 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootCD-4.2-15
227 - record the ntp time to the hwclock.  this is a bootcd operation, but it is
228 - repeated in the bootmanager to handle all CDs without this operation
229
230 * Mon Jun 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootCD-4.2-14
231 - Daniel''s update to generalize the kvariant support.
232
233 * Wed Apr 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-13
234 - robust to node config file specified with a relative path
235
236 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-12
237 - fix specfile - 4.2-11 would not build
238
239 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-11
240 - Added support for handling kernel variants
241 - http://svn.planet-lab.org/wiki/BootcdVariant
242
243 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-10
244 - mkfs.vfat output removed prior to invokation - fix needed on fedora 10
245
246 * Tue Dec 30 2008 Marc Fiuczynski <mef@cs.princeton.edu> - BootCD-4.2-9
247 - Added kupdate.sh
248
249 * Sat Dec 13 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - BootCD-4.2-8
250 - Use pyplnet.
251 - Add a site_admin account to the BootCD.
252 - Add some explanations for common errors.
253
254 * Tue Dec 02 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - BootCD-4.2-7
255 - Allow multiple -k options to the build.sh script.
256 - Probe devices in PCI bus order.
257
258 * Fri Nov 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-6
259 - add support for fedora9 images - compliant with upstart
260 - formerly monolythic dir 'conf_files/' split into 'etc/' and 'initscripts/'
261
262 * Tue Sep 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-5
263 - cosmetic - pl_boot to display timestamps
264
265 * Mon Aug 04 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - BootCD-4.2-4
266 - adds -k as an argument to build.sh to pass additional kernel parameters to the
267 - bootcd and kexec kernel.
268
269 * Mon May 05 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-3
270 - rpm release tag does not need pldistro as it is already part of the rpm name
271
272 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-2
273 - change location of nodefamily in /etc/planetlab/
274
275 * Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-1
276 - new name for the rpm, to allow simultaneous rpm-installs for several nodefamily (pldistro+arch)
277 - now installs in /usr/share/bootcd-<nodefamily> with a legacy symlink (requires MyPLC-4.2-7) 
278 - nodefamily exported under bootcd.img in /etc/nodefamily (for bm) and under build/nodefamily (for build.sh)
279
280 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-3.4-4 BootCD-3.4-5
281 - kargs.txt for serial boot fixed: now properly exposed to bootmanager through the overlay image
282 - build.sh cleaned up in the process
283 - actual location of selected node config file displayed
284 - import pypci rather than pypciscan
285
286 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-3.4-3 bootcd-3.4-4
287 - build.sh support for -s <console_spec> (recommended vs using type)
288 - build.sh cleanup - usage clearer wrt types - removed old code
289 - fixed modprobe with args in pl_hwinit
290
291 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-3.4-2 bootcd-3.4-3
292 - load floppy with modprobe flags
293 - support for creating a usb partition
294 - removed obsolete files newbuild.sh, bootcustom.sh and cdcustom.sh
295
296 * Mon Jan 29 2006 Marc E. Fiuczynski <mef@cs.princeton.edu> - 
297 - added biginitrd usb image
298
299 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
300 - Initial build.
301
302 %define module_current_branch 4.2