- merge revision 1.2
[bootcd.git] / bootcd.spec
index 45c4f84..577f6ba 100644 (file)
@@ -48,6 +48,9 @@ popd
 # If run under sudo, allow user to delete the build directory
 if [ -n "$SUDO_USER" ] ; then
     chown -R $SUDO_USER .
+    # Some temporary cdroot files like /var/empty/sshd and
+    # /usr/bin/sudo get created with non-readable permissions.
+    find . -not -perm +0600 -exec chmod u+rw {} \;
 fi
 
 %clean