remove default console=ttyS0,115200 and systemd.log_target=console from default kargs
[bootcd.git] / bootcd.spec
index c801cac..4e03a8d 100644 (file)
@@ -1,16 +1,11 @@
 #
-# $Id$
-#
-%define url $URL$
-
 %define nodefamily %{pldistro}-%{distroname}-%{_arch}
 
 %define name bootcd-%{nodefamily}
-%define version 5.0
-%define taglevel 0
+%define version 5.2
+%define taglevel 5
 
 # pldistro already in the rpm name
-#%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 %define release %{taglevel}%{?date:.%{date}}
 
 # structure - this results in 2 packages
@@ -20,7 +15,7 @@
 Vendor: PlanetLab
 Packager: PlanetLab Central <support@planet-lab.org>
 Distribution: PlanetLab %{plrelease}
-URL: %(echo %{url} | cut -d ' ' -f 2)
+URL: %{SCMURL}
 
 Summary: Boot CD material for %{nodefamily}
 Name: %{name}
@@ -34,9 +29,20 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 BuildArch: noarch
 
 Requires: dosfstools, mkisofs, gzip, mtools, syslinux
+# yumdownloader is needed in bootcd-kernel
+Requires: yum-utils
+# mkdiskimage is used for USB-partitioned mode
+# but it now comes in a separate rpm
+%if "%{distro}" == "Fedora" && %{distrorelease} >= 14
+Requires: syslinux-perl
+%endif
 
 Requires: pyplnet
 
+# 5.0 now has 3-fold nodefamily
+%define obsolete_nodefamily %{pldistro}-%{_arch}
+Obsoletes: bootcd-%{obsolete_nodefamily}
+
 AutoReqProv: no
 %define debug_package %{nil}
 
@@ -63,17 +69,19 @@ Conflicts: MyPLC <= 4.3
 %setup -q
 
 %build
-pushd BootCD
+[ -d bootcd ] || ln -s BootCD bootcd
+
+pushd bootcd
 
-# Build the reference image
-./prep.sh %{pldistro} %{nodefamily}
+# Build the reference image - pass 3-fold version number to go in version.txt
+./prep.sh %{pldistro} %{nodefamily} %{version}
 
 popd
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-pushd  BootCD
+pushd bootcd
 
 # Install the reference image and build scripts
 install -d -m 755 $RPM_BUILD_ROOT/%{_datadir}/%{name}
@@ -91,6 +99,7 @@ tar cpf - \
 for script in bootcd bootcd-kernel; do 
     install -D -m 755 plc.d/$script $RPM_BUILD_ROOT/etc/plc.d/$script
 done
+
 popd
     
 %clean
@@ -105,6 +114,81 @@ rm -rf $RPM_BUILD_ROOT
 /etc/plc.d
 
 %changelog
+* Fri Apr 03 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.2-5
+- changes for fedora 21 and its new release of syslinux
+
+* Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.2-4
+- no change, only some internal comments were changed
+
+* Wed Jun 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.2-3
+- attempt to make node take off more reliable with pl_wrapper
+
+* Wed Apr 24 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.2-2
+- fix version number as it shows up in version.txt (was empty)
+
+* Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.2-1
+- turn off systemd traces at boot-time
+
+* Tue Feb 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.1-5
+- fix console on tty2: this broke the build on fedora14
+- even though f14 doesn't use systemd by defaults there is /etc/systemd in there
+
+* Fri Feb 22 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.1-4
+- turn on getty/console on tty2
+
+* Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.1-3
+- reviewed for systemd & f18
+
+* Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.1-2
+- turn off selinux, turns out needed with some combinations like lxc/f14
+
+* Wed Apr 11 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.1-1
+- compatible with pre- and post- f16
+- add systemd friendlyness to bootcd
+- also add biosdevname=0 tp kernel args so ethernet devices are still named in eth<x>
+
+* Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.0-11
+- add requires: to syslinux-perl on fedora14
+
+* Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.0-10
+- blacklisted mdules
+- requires yum-utils for yumdownloader in bootcd-kernel
+
+* Mon Feb 21 2011 S.Çağlar Onur <caglar@verivue.com> - bootcd-5.0-9
+- Handle /dev/rtc name change for newer kernels
+
+* Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - bootcd-5.0-8
+- Revert hacky solution for 2.6.32 based kernels as they are no longer required
+
+* Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.0-7
+- changes for booting off fedora14
+- displays some sanity checks in case bm can's get downloaded
+- virtio devices in /dev/vd* also considered
+- start service rsyslog if found
+- hack for kernel-firmware with 2.6.32
+- use $() instead of ``
+
+* Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.0-6
+- use /usr/lib/syslinux/mkdiskimage or installed mkdiskimage
+
+* Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.0-5
+- remove remainging reference to planet-lab.org
+
+* Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootCD-5.0-4
+- module name changes
+
+* Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-5.0-3
+- nicer initscript now uses 'action' from /etc/init.d/functions
+
+* Tue Apr 20 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootCD-5.0-2
+- obsolete old bootcd versions
+
+* Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-5.0-1
+- First working version of 5.0:
+- pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
+- nodefamily is 3-fold with pldistro-fcdistro-arch
+- new module bootcd-inistscripts
+
 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-17
 - support for fedora 12