password generation utility was still python2
[bootcd.git] / bootcd.spec
index 9d0c428..8890bec 100644 (file)
@@ -2,11 +2,10 @@
 %define nodefamily %{pldistro}-%{distroname}-%{_arch}
 
 %define name bootcd-%{nodefamily}
-%define version 5.0
-%define taglevel 8
+%define version 6.0
+%define taglevel 0
 
 # pldistro already in the rpm name
-#%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 %define release %{taglevel}%{?date:.%{date}}
 
 # structure - this results in 2 packages
@@ -29,7 +28,14 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 # other archs must be able to install this
 BuildArch: noarch
 
-Requires: dosfstools, mkisofs, gzip, mtools, syslinux
+Requires: dosfstools, genisoimage, gzip, mtools, syslinux
+# yumdownloader is needed in bootcd-kernel
+Requires: yum-utils
+# mkdiskimage is used for USB-partitioned mode
+# but it now comes in a separate rpm
+%if "%{distro}" == "Fedora" && %{distrorelease} >= 14
+Requires: syslinux-perl
+%endif
 
 Requires: pyplnet
 
@@ -67,8 +73,8 @@ Conflicts: MyPLC <= 4.3
 
 pushd bootcd
 
-# Build the reference image
-./prep.sh %{pldistro} %{nodefamily}
+# Build the reference image - pass 3-fold version number to go in version.txt
+./prep.sh %{pldistro} %{nodefamily} %{version}
 
 popd
 
@@ -93,6 +99,7 @@ tar cpf - \
 for script in bootcd bootcd-kernel; do 
     install -D -m 755 plc.d/$script $RPM_BUILD_ROOT/etc/plc.d/$script
 done
+
 popd
     
 %clean
@@ -107,6 +114,77 @@ rm -rf $RPM_BUILD_ROOT
 /etc/plc.d
 
 %changelog
+* Mon Jan 07 2019 Thierry <Parmentelat> - bootcd-6.0-0
+- requires 'genisoimage' rather than deprecated 'mkisofs'
+- set kernel arg `net.ifnames=0` in addition to `biosdevname=0`
+- does not use ifconfig, instead use ip and nm-ifup, or look up /sys/class/net
+- slightly review the contents of forensics messages
+
+* Sun Jul 10 2016 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.4-1
+- use 8.8.8.8 s a DNS server if nothing else works
+- more consistent and verbose forensics system
+
+* Tue Dec 08 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.3-3
+- patch for f23 as of dec. 2015 where kernel and initrd show up in
+- a new location under /boot
+
+* Fri Nov 13 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.3-2
+- various fixes for resolv.conf
+
+* Fri Jun 26 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.3-1
+- use TLSv1 instead of SSLv3
+- on systemd distros, do not try to replace the whole boot sequence
+- as older bootCDs did; pl_boot is now just one more service, not the single
+- service to run; this solves f21 bootCDs not starting up properly
+
+* Fri Apr 24 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.2-6
+- remove default kargs systemd.log_target=console console=ttyS0,115200
+- simpler bootcd layout (no memdisk nor isolinux-debug.bin)
+- keep track of actual kargs in log file for build.sh
+
+* Fri Apr 03 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.2-5
+- changes for fedora 21 and its new release of syslinux
+
+* Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.2-4
+- no change, only some internal comments were changed
+
+* Wed Jun 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.2-3
+- attempt to make node take off more reliable with pl_wrapper
+
+* Wed Apr 24 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.2-2
+- fix version number as it shows up in version.txt (was empty)
+
+* Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.2-1
+- turn off systemd traces at boot-time
+
+* Tue Feb 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.1-5
+- fix console on tty2: this broke the build on fedora14
+- even though f14 doesn't use systemd by defaults there is /etc/systemd in there
+
+* Fri Feb 22 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.1-4
+- turn on getty/console on tty2
+
+* Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.1-3
+- reviewed for systemd & f18
+
+* Mon May 07 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.1-2
+- turn off selinux, turns out needed with some combinations like lxc/f14
+
+* Wed Apr 11 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.1-1
+- compatible with pre- and post- f16
+- add systemd friendlyness to bootcd
+- also add biosdevname=0 tp kernel args so ethernet devices are still named in eth<x>
+
+* Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.0-11
+- add requires: to syslinux-perl on fedora14
+
+* Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-5.0-10
+- blacklisted mdules
+- requires yum-utils for yumdownloader in bootcd-kernel
+
+* Mon Feb 21 2011 S.Çağlar Onur <caglar@verivue.com> - bootcd-5.0-9
+- Handle /dev/rtc name change for newer kernels
+
 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - bootcd-5.0-8
 - Revert hacky solution for 2.6.32 based kernels as they are no longer required