Branch 4.2 for module BootCD created from tag BootCD-3.4-5
[bootcd.git] / bootcd.spec
index d3ca071..935777c 100644 (file)
@@ -1,14 +1,21 @@
+#
+# $Id$
+#
+%define url $URL$
+
 %define name bootcd
-%define version 3.3
-%define release 2%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+%define version 3.4
+%define taglevel 5
+
+%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
 Vendor: PlanetLab
 Packager: PlanetLab Central <support@planet-lab.org>
-Distribution: PlanetLab 3.3
-URL: http://cvs.planet-lab.org/cvs/bootcd
+Distribution: PlanetLab %{plrelease}
+URL: %(echo %{url} | cut -d ' ' -f 2)
 
 Summary: Boot CD
-Name: bootcd
+Name: %{name}
 Version: %{version}
 Release: %{release}
 License: BSD
@@ -16,7 +23,7 @@ Group: System Environment/Base
 Source0: %{name}-%{version}.tar.gz
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 
-Requires: dosfstools, mkisofs, gzip
+Requires: dosfstools, mkisofs, gzip, mtools, syslinux
 
 AutoReqProv: no
 %define debug_package %{nil}
@@ -25,53 +32,33 @@ AutoReqProv: no
 The Boot CD securely boots PlanetLab nodes into an immutable
 environment.
 
-%package planetlab
-Summary: PlanetLab Boot CD
-Group: System Environment/Base
-
-%description planetlab
-The default PlanetLab Boot CD, customized to boot from PlanetLab
-Central servers.
-
 %prep
 %setup -q
 
 %build
-pushd bootcd
+pushd BootCD
 
 # Build the reference image
-./prep.sh
-
-# Build the default configuration (PlanetLab)
-./build.sh
-
-md5sum PlanetLab-BootCD-%{version}.{iso,usb} \
-    >PlanetLab-BootCD-%{version}.md5
+./prep.sh %{pldistro}
 
 popd
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-pushd bootcd
+pushd  BootCD
 
 # Install the reference image and build scripts
 install -d -m 755 $RPM_BUILD_ROOT/%{_datadir}/%{name}
 install -m 755 build.sh $RPM_BUILD_ROOT/%{_datadir}/%{name}/
-find \
+tar cpf - \
     build/isofs/bootcd.img \
-    build/isofs/isolinux.bin \
     build/isofs/kernel \
     build/passwd \
     build/version.txt \
-    configurations \
-    syslinux/unix/syslinux | \
-    cpio -p -d -u $RPM_BUILD_ROOT/%{_datadir}/%{name}/
-
-# Install the default images in the download/ directory
-install -d -m 755 $RPM_BUILD_ROOT/var/www/html/download
-install -m 644 PlanetLab-BootCD-%{version}.* \
-    $RPM_BUILD_ROOT/var/www/html/download/
+       bootcustom.sh \
+    configurations | \
+    tar -C $RPM_BUILD_ROOT/%{_datadir}/%{name}/ -xpf -
 
 popd
     
@@ -81,30 +68,35 @@ rm -rf $RPM_BUILD_ROOT
 # If run under sudo
 if [ -n "$SUDO_USER" ] ; then
     # Allow user to delete the build directory
-    chown -R $SUDO_USER .
+    chown -h -R $SUDO_USER .
     # Some temporary cdroot files like /var/empty/sshd and
     # /usr/bin/sudo get created with non-readable permissions.
     find . -not -perm +0600 -exec chmod u+rw {} \;
     # Allow user to delete the built RPM(s)
-    chown -R $SUDO_USER %{_rpmdir}/%{_arch}
+    chown -h -R $SUDO_USER %{_rpmdir}/%{_arch}
 fi
 
-%post planetlab
-cat <<EOF
-Remember to GPG sign
-/var/www/html/download/PlanetLab-BootCD-%{version}.{iso,usb} with
-the PlanetLab private key.
-EOF
-
 %files
 %defattr(-,root,root,-)
 %{_datadir}/%{name}
 
-%files planetlab
-%defattr(-,root,root,-)
-/var/www/html/download
-
 %changelog
+* Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-3.4-4 BootCD-3.4-5
+- kargs.txt for serial boot fixed: now properly exposed to bootmanager through the overlay image
+- build.sh cleaned up in the process
+- actual location of selected node config file displayed
+- import pypci rather than pypciscan
+
+* Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-3.4-3 bootcd-3.4-4
+- build.sh support for -s <console_spec> (recommended vs using type)
+- build.sh cleanup - usage clearer wrt types - removed old code
+- fixed modprobe with args in pl_hwinit
+
+* Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootcd-3.4-2 bootcd-3.4-3
+- load floppy with modprobe flags
+- support for creating a usb partition
+- removed obsolete files newbuild.sh, bootcustom.sh and cdcustom.sh
+
 * Mon Jan 29 2006 Marc E. Fiuczynski <mef@cs.princeton.edu> - 
 - added biginitrd usb image