Setting tag bootcd-4.2-25
[bootcd.git] / bootcd.spec
index 9dfc02e..ce031e2 100644 (file)
@@ -7,7 +7,7 @@
 
 %define name bootcd-%{nodefamily}
 %define version 4.2
-%define taglevel 9
+%define taglevel 25
 
 # pldistro already in the rpm name
 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
@@ -30,6 +30,10 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 BuildArch: noarch
 
 Requires: dosfstools, mkisofs, gzip, mtools, syslinux
+# yumdownloader is needed in bootcd-kernel
+Requires: yum-utils
+
+Requires: pyplnet
 
 AutoReqProv: no
 %define debug_package %{nil}
@@ -42,6 +46,7 @@ environment.
 %setup -q
 
 %build
+[ -d BootCD ] || ln -s bootcd BootCD
 pushd BootCD
 
 # Build the reference image
@@ -57,7 +62,7 @@ pushd  BootCD
 # Install the reference image and build scripts
 install -d -m 755 $RPM_BUILD_ROOT/%{_datadir}/%{name}
 install -m 755 build.sh $RPM_BUILD_ROOT/%{_datadir}/%{name}/
-install -m 755 kupdate.sh $RPM_BUILD_ROOT/%{_datadir}/%{name}/
+install -m 755 kvariant.sh $RPM_BUILD_ROOT/%{_datadir}/%{name}/
 tar cpf - \
     build/isofs/bootcd.img \
     build/isofs/kernel \
@@ -80,7 +85,7 @@ if [ -n "$SUDO_USER" ] ; then
     # /usr/bin/sudo get created with non-readable permissions.
     find . -not -perm +0600 -exec chmod u+rw {} \;
     # Allow user to delete the built RPM(s)
-    chown -h -R $SUDO_USER %{_rpmdir}/%{_arch}
+    chown -h -R $SUDO_USER %{_rpmdir}/*
 fi
 
 %files
@@ -91,6 +96,57 @@ fi
 [ -f /etc/planetlab/nodefamily ] || { mkdir -p /etc/planetlab ; echo %{nodefamily} > /etc/planetlab/nodefamily ; }
 
 %changelog
+* Mon Mar 21 2011 S.Çağlar Onur <caglar@verivue.com> - bootcd-4.2-25
+- requires yum-utils for yumdownloader in bootcd-kernel
+
+* Tue Mar 15 2011 S.Çağlar Onur <caglar@verivue.com> - bootcd-4.2-24
+- Remove hardcoded file list
+
+* Tue Mar 15 2011 S.Çağlar Onur <caglar@verivue.com> - bootcd-4.2-23
+- cherry-pick changesets from master to support SL6
+
+* Tue Mar 08 2011 S.Çağlar Onur <caglar@verivue.com> - bootcd-4.2-22
+- Support virtio block devices
+
+* Tue Mar 01 2011 S.Çağlar Onur <caglar@verivue.com> - bootcd-4.2-21
+- do not try to load blacklisted modules
+- handle /dev/rtc name change for newer kernels
+
+* Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - bootcd-4.2-20
+- Revert hacky solution for 2.6.32 based kernels as they are no longer required
+
+* Tue Jan 18 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - bootcd-4.2-19
+- Introduce a quick hack for 2.6.32 based BootCD
+
+* Thu Jan 06 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - bootcd-4.2-18
+- handle directory name changes
+
+* Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-17
+- support for fedora 12
+
+* Sun Dec 27 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-16
+- fix build on fedora12
+
+* Fri Sep 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootCD-4.2-15
+- record the ntp time to the hwclock.  this is a bootcd operation, but it is
+- repeated in the bootmanager to handle all CDs without this operation
+
+* Mon Jun 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootCD-4.2-14
+- Daniel's update to generalize the kvariant support.
+
+* Wed Apr 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-13
+- robust to node config file specified with a relative path
+
+* Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-12
+- fix specfile - 4.2-11 would not build
+
+* Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-11
+- Added support for handling kernel variants
+- http://svn.planet-lab.org/wiki/BootcdVariant
+
+* Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootCD-4.2-10
+- mkfs.vfat output removed prior to invokation - fix needed on fedora 10
+
 * Tue Dec 30 2008 Marc Fiuczynski <mef@cs.princeton.edu> - BootCD-4.2-9
 - Added kupdate.sh