Silent following warning;
[bootmanager.git] / bootmanager.spec
index 8d6081e..156153e 100644 (file)
@@ -5,7 +5,7 @@
 
 %define name bootmanager
 %define version 4.3
-%define taglevel 3
+%define taglevel 24
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -40,6 +40,7 @@ nodes.
 %setup -q
 
 %build
+gcc -shared -fPIC -ldl -Os -o source/libc-opendir-hack.so source/libc-opendir-hack.c
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -73,6 +74,10 @@ Remember to GPG sign /var/www/html/boot/bootmanager.sh with the
 PlanetLab private key.
 EOF
 
+# NOTE: do not run this agent when installed on a myplc.
+chkconfig monitor-runlevelagent off
+chkconfig --del monitor-runlevelagent
+
 %files
 %defattr(-,root,root,-)
 %{_datadir}/%{name}
@@ -80,6 +85,87 @@ EOF
 /var/www/html/boot/uudecode.gz
 
 %changelog
+* Tue Mar 15 2011 S.Çağlar Onur <caglar@verivue.com> - bootmanager-4.3-24
+- Remove hardcoded file list
+
+* Tue Mar 15 2011 S.Çağlar Onur <caglar@verivue.com> - bootmanager-4.3-23
+- cherry-pick changesets from master to support SL6
+
+* Fri Mar 11 2011 S.Çağlar Onur <caglar@verivue.com> - bootmanager-4.3-22
+- Add missing include
+
+* Wed Mar 09 2011 S.Çağlar Onur <caglar@verivue.com> - bootmanager-4.3-21
+- Support virtio block devices
+
+* Fri Jan 07 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - bootmanager-4.3-20
+- add --allow-missing parameter to support different kernel configs
+
+* Tue Dec 14 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - bootmanager-4.3-19
+- Force removal of VG for automation.
+
+* Fri Nov 19 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - bootmanager-4.3-18
+- Use resize2fs for resizing.
+- Fix typo for VSERVERS_SIZE.
+- Disable time/count-based fsck.
+
+* Fri Feb 19 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - BootManager-4.3-17
+- merge initrd changes from trunk
+
+* Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-16
+- support for fedora 12
+
+* Sat Dec 19 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-15
+- - support for when the node is behind a NAT
+- - clean up RUN_LEVEL support
+- - support for early sshd
+
+* Thu Nov 19 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - BootManager-4.3-14
+- Add NAT model option for nodes which don't resolve properly.
+
+* Mon Sep 07 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-12
+- Moved some configuration values from BootServerRequest.py to 'configuration' file.
+- BootServerRequest takes the 'VARS' variable to read these values.
+- UPLOAD_LOG_SCRIPT can point optionally to the 'upload-bmlog.php' or 'monitor/upload'
+- (or any other interface that accepts a POST file)
+- build.sh bundles cacerts for boot and monitor servers (if present) to
+- authenticate the UPLOAD_LOG_SCRIPT.
+- Previously, these certs were re-used from the bootcd, now they are bundled
+- with BM.  This allows the BM to point to a completely different myplc if
+- desired, and it is still secure, because the original download is
+- authenticated.
+
+* Wed Aug 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-11
+- raise a single exception for nodes with authentication errors
+- fix syntax error in MakeInitrd.py
+
+* Mon Aug 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-10
+- Replace UpdateBootstate with UpdateRunlevel where appropriate.
+- Removed failboot and install from forced states.
+- Removed checks for initrd in Validate
+- Added extra messages for Validate failures, not-installed, no kernel, failed fsck
+- Added libc-opendir-hack.so patch from 3.2 branch for 2.6.12 bootcds on PL.
+
+* Mon Jun 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-9
+- Special handling for "forcedeth" ethernet NIC.
+
+* Mon Jun 15 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - BootManager-4.3-8
+- include a fix for public pl dealing with old/new boot images and root
+- environments
+
+* Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-7
+- review selection nodefamily at bootstrapfs install-time
+- now based on (1) tags (2) nodefamily and (3) defaults
+- this is required on very old bootcd
+
+* Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - BootManager-4.3-6
+- Use modprobe module to write out /etc/modprobe.conf.
+
+* Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-5
+- minor updates - using the new modprobe module *not* in this tag
+
+* Wed Apr 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-4
+- load device mapper if needed, for centos5-based bootcd variant
+
 * Wed Mar 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootManager-4.3-3
 - renumbered 4.3
 - New step StartRunLevelAgent