reguire gnupg1 on f>=31; sense the system to use gpg1 when installed
[bootmanager.git] / bootmanager.spec
index 20fb2a8..a383393 100644 (file)
@@ -1,7 +1,7 @@
 #
 %define name bootmanager
-%define version 5.3
-%define taglevel 3
+%define version 6.0
+%define taglevel 0
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -23,7 +23,14 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 # this is not true anymore and fedora23 won't let us build this as noarch anymore
 # BuildArch: noarch
 
-Requires: tar, gnupg, sharutils, bzip2
+Requires: tar, sharutils, bzip2
+# see myplc/plc.d/gpg for more details on the gnupg / gpg topic
+%if "%{distro}" == "Fedora" && %{distrorelease} >= 31
+Requires: gnupg1
+%else
+Requires: gnupg
+%endif
+
 # need the apache user at install-time
 Requires: httpd 
 
@@ -85,6 +92,22 @@ chmod 700 /var/log/bm
 /etc/plc.d/bootmanager
 
 %changelog
+* Mon Jan 07 2019 Thierry <Parmentelat> - bootmanager-6.0-0
+- * this is STILL BASED ON PYTHON2, but relies on 2 accessory libraries that are pypcilib and pyplnet
+- for this reason, the relevant files are COPIED at packaging time
+- * new settings lxc_ROOT_SIZE=12G (was 70G) and SWAP_SIZE=4G (was 1G)
+- and lxc_TOTAL_MINIMUM_DISK_SIZE=50 (was 120)
+- * invoke conf_files.py as a plain script (i.e. expects a shebang) since we ideally can still
+- use this code against a python2 nodemanager
+- * skip nodeupdate step, will be redone later anyway
+- * rely on NetworkManager utilities when ifconfig can't be found
+- * tear down patch for very old 2.6.12 kernels
+- * a little closer to python3 though
+
+* Sun Jan 10 2016 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.3-4
+- runlevelagent was not able to reach myplc because of
+- server verification that is now implicit in python 2.7.9
+
 * Tue Dec 08 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.3-3
 - patch for f23 as of dec. 2015 where kernel and initrd show up in
 - a new location under /boot