reguire gnupg1 on f>=31; sense the system to use gpg1 when installed
[bootmanager.git] / bootmanager.spec
index 2b0dea8..a383393 100644 (file)
@@ -1,7 +1,7 @@
 #
 %define name bootmanager
-%define version 5.2
-%define taglevel 2
+%define version 6.0
+%define taglevel 0
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -18,9 +18,19 @@ License: BSD
 Group: System Environment/Base
 Source0: %{name}-%{version}.tar.gz
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
-BuildArch: noarch
+# in theory this should be a noarch rpm
+# however because of libc-opendir-hack (which apparently targets f12 bootCDs)
+# this is not true anymore and fedora23 won't let us build this as noarch anymore
+# BuildArch: noarch
+
+Requires: tar, sharutils, bzip2
+# see myplc/plc.d/gpg for more details on the gnupg / gpg topic
+%if "%{distro}" == "Fedora" && %{distrorelease} >= 31
+Requires: gnupg1
+%else
+Requires: gnupg
+%endif
 
-Requires: tar, gnupg, sharutils, bzip2
 # need the apache user at install-time
 Requires: httpd 
 
@@ -82,6 +92,54 @@ chmod 700 /var/log/bm
 /etc/plc.d/bootmanager
 
 %changelog
+* Mon Jan 07 2019 Thierry <Parmentelat> - bootmanager-6.0-0
+- * this is STILL BASED ON PYTHON2, but relies on 2 accessory libraries that are pypcilib and pyplnet
+- for this reason, the relevant files are COPIED at packaging time
+- * new settings lxc_ROOT_SIZE=12G (was 70G) and SWAP_SIZE=4G (was 1G)
+- and lxc_TOTAL_MINIMUM_DISK_SIZE=50 (was 120)
+- * invoke conf_files.py as a plain script (i.e. expects a shebang) since we ideally can still
+- use this code against a python2 nodemanager
+- * skip nodeupdate step, will be redone later anyway
+- * rely on NetworkManager utilities when ifconfig can't be found
+- * tear down patch for very old 2.6.12 kernels
+- * a little closer to python3 though
+
+* Sun Jan 10 2016 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.3-4
+- runlevelagent was not able to reach myplc because of
+- server verification that is now implicit in python 2.7.9
+
+* Tue Dec 08 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.3-3
+- patch for f23 as of dec. 2015 where kernel and initrd show up in
+- a new location under /boot
+- plus bugfix with format and single { and } for awk args
+
+* Fri Nov 13 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.3-2
+- not a noarch package anymore (indeed it does come with binaries)
+- fix ssl connection for runlevelagent for recent pythons
+- for fedora23, ignore if rsa1 key generation fails
+
+* Fri Jun 26 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.3-1
+- Use TLSv1 to connect to myplc, instead of SSLv3 that is known to be broken
+- Can implement 'upgrade' in addition to 'reinstall' boot state
+- upgrade does essentially the same as reinstall except that slices are preserved
+- upgrade works only on nodes already running containers
+- because /vservers/ needs to be a btrfs filesystem
+- pycurl is now a strong requirement (old curl-based code removed)
+- bugfix for ssh key generation (were all typed rsa1)
+- a lot of prettification
+
+* Wed Jul 16 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.2-5
+- runs AnsibleHook, that optionnally runs playbooks (by default, usual behaviour)
+- introduces the ONE_PARTITION configuration variable
+- some suport for chainbooting ubuntu
+
+* Mon Apr 28 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.2-4
+- no functional change, only tweaks in Makefile for interating with test environment
+
+* Tue Mar 25 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.2-3
+- some old f18 bootCDs do not support mkfs.btrfs -f
+- so invoke this option only when supported
+
 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.2-2
 - conf_files.py is expected in /usr/share/NodeManager, not in /etc/init.d any more
 - smarter for locating initrd, for f20