bugfixes for the location of kernel and initrd as observed on recent f23
[bootmanager.git] / bootmanager.spec
index 13cb673..bfee338 100644 (file)
@@ -1,7 +1,7 @@
 #
 %define name bootmanager
-%define version 5.2
-%define taglevel 0
+%define version 5.3
+%define taglevel 1
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -18,14 +18,18 @@ License: BSD
 Group: System Environment/Base
 Source0: %{name}-%{version}.tar.gz
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
-BuildArch: noarch
+# in theory this should be a noarch rpm
+# however because of libc-opendir-hack (which apparently targets f12 bootCDs)
+# this is not true anymore and fedora23 won't let us build this as noarch anymore
+# BuildArch: noarch
 
-Requires: tar, gnupg, sharutils, bzip2, pypcilib
+Requires: tar, gnupg, sharutils, bzip2
 # need the apache user at install-time
 Requires: httpd 
 
-Requires: PLCAPI >= 5.0
-# the python code packaged in these are shipped on the node as well
+Requires: plcapi >= 5.2
+# we need to install these on the myplc side too, although this is suboptimal
+# b/c this python code gets shipped on the nodes as well
 Requires: pypcilib pyplnet
 
 ### avoid having yum complain about updates, as stuff is moving around
@@ -81,15 +85,69 @@ chmod 700 /var/log/bm
 /etc/plc.d/bootmanager
 
 %changelog
+* Fri Jun 26 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.3-1
+- Use TLSv1 to connect to myplc, instead of SSLv3 that is known to be broken
+- Can implement 'upgrade' in addition to 'reinstall' boot state
+- upgrade does essentially the same as reinstall except that slices are preserved
+- upgrade works only on nodes already running containers
+- because /vservers/ needs to be a btrfs filesystem
+- pycurl is now a strong requirement (old curl-based code removed)
+- bugfix for ssh key generation (were all typed rsa1)
+- a lot of prettification
+
+* Wed Jul 16 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.2-5
+- runs AnsibleHook, that optionnally runs playbooks (by default, usual behaviour)
+- introduces the ONE_PARTITION configuration variable
+- some suport for chainbooting ubuntu
+
+* Mon Apr 28 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.2-4
+- no functional change, only tweaks in Makefile for interating with test environment
+
+* Tue Mar 25 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.2-3
+- some old f18 bootCDs do not support mkfs.btrfs -f
+- so invoke this option only when supported
+
+* Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.2-2
+- conf_files.py is expected in /usr/share/NodeManager, not in /etc/init.d any more
+- smarter for locating initrd, for f20
+- add -f to mkfs.btrfs - sometimes hangs otherwise
+
+* Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.2-1
+- merged the branches for vserver and lxc
+- requires the rest of 5.2 - notably 'virt' in GetNodeFlavour
+- note that WriteModprobeConfig and MakeInitrd are turned off for lxc nodes
+- also note that fsck management for btrfs/lxc is still weak
+- vs_ROOT_SIZE=14G lxc_ROOT_SIZE=70G
+- vs_TOTAL_MINIMUM_DISK_SIZE=50G lxc_TOTAL_MINIMUM_DISK_SIZE=120G
+- expects ntpd to be turned on in the nodeimage
+
+* Fri Feb 22 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-5
+- fix for heterogeneous bootimage/nodeimage
+
+* Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-4
+- Turn off WriteModprobeConfig for f18
+- enable btrfs quota
+- fix very old ssh DSA key generation
+
+* Tue Oct 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-3
+- run parted with --script to keep it from hanging
+
 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-24
 - run parted with --script to avoid it to hang
 
+* Wed Jul 18 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-2
+- pour the 5.0-22 and 5.0-23 features into the lxc mix
+
 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-23
 - added support for disks larger than 2Tb using gpt instead of msdos
 
 * Tue May 15 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-22
 - bootmanager log clearly states duration of download and extraction of node image
 
+* Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.1-1
+- first working draft for dealing with f16 nodes
+- not expected to work with mainline nodes (use 5.0 for that for now)
+
 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootmanager-5.0-21
 - no significant change, just checkpoint as 5.1 is addressing lxc
 
@@ -281,4 +339,3 @@ chmod 700 /var/log/bm
 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
 - Initial build.
 
-%define module_current_branch 4.3