Setting tag nodeimage-5.2-9
[bootstrapfs.git] / nodeimage.spec
1 %define nodefamily %{pldistro}-%{distroname}-%{_arch}
2 %define extensionfamily %{distroname}-%{_arch}
3
4 %define name nodeimage-%{nodefamily}
5 %define version 5.2
6 %define taglevel 9
7
8 # pldistro already in the rpm name
9 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
10 %define release %{taglevel}%{?date:.%{date}}
11
12 # we don't really need the standard postinstall process from rpm that
13 # strips files and byte-compiles python files. all files in this
14 # package are comming from other rpm files and they've already went
15 # through this post install processing. - baris
16 %define __os_install_post %{nil}
17
18 Vendor: PlanetLab
19 Packager: PlanetLab Central <support@planet-lab.org>
20 Distribution: PlanetLab %{plrelease}
21 URL: %{SCMURL}
22
23 Summary: The PlanetLab nodeimage filesystems for %{nodefamily}
24 Name: %{name}
25 Version: %{version}
26 Release: %{release}
27 License: BSD
28 Group: System Environment/Base
29 Source0: %{name}-%{version}.tar.gz
30 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
31 # other archs must be able to install this
32 BuildArch: noarch
33
34 Requires: tar, gnupg, sharutils, bzip2
35 # this is for plc.d/packages that uses ed for hacking yumgroups.xml
36 Requires: ed
37
38 # 5.1 now uses new name nodeimage
39 Obsoletes: bootstrapfs-%{nodefamily}
40 # 5.0 now has 3-fold nodefamily
41 %define obsolete_nodefamily %{pldistro}-%{_arch}
42 Obsoletes: bootstrapfs-%{obsolete_nodefamily}
43
44 AutoReqProv: no
45 %define debug_package %{nil}
46
47 %description
48
49 The PlanetLab nodeimage filesystem is downloaded by the
50 BootManager to reinstall a node with a new filesystem.
51
52 %package plain
53 Summary: The (uncompressed) PlanetLab nodeimage filesystem for %{nodefamily}
54 Group: System Environment/Base
55 %description plain
56 This package provides the same functions as %{name} but with uncompressed tarball for faster tests.
57
58 %package -n nodeyum
59 Summary: the MyPLC-side utilities for tweaking nodes yum configs
60 Group: System Environment/Base
61 %description -n nodeyum 
62 Utility scripts for configuring node updates. This package is designed
63 for the MyPLC side.
64
65 %prep
66 %setup -q
67
68 %build
69
70 ############################## node-side
71 pushd nodeimage
72 ./build.sh %{pldistro} 
73 for tar in *.tar *.tar.bz2; do 
74     start=$(date +%H-%M-%S)
75     sha1sum $tar > $tar.sha1sum
76     chmod 444 $tar.sha1sum
77     end=$(date +%H-%M-%S)
78     echo "* Computed SHA1 checksum for $tar ($start .. $end) "
79 done
80 popd
81
82 ############################## server-side
83 # ship all fcdistros for multi-fcdistros myplc, and let the php scripts do the right thing
84 pushd nodeimage/nodeconfig/yum
85 # scan fcdistros and catenate all repos in 'stock.repo' so db-config can be distro-independant
86 for fcdistro in $(ls); do
87     [ -d $fcdistro ] || continue
88     # get packages to exclude on nodes for that fcdistro/pldistro
89     NODEYUMEXCLUDE="exclude=$(../../../build/nodeyumexclude.sh $fcdistro %{pldistro})"
90     pushd $fcdistro/yum.myplc.d
91     echo "* Handling NODEYUMEXCLUDE in yum repo for $fcdistro/$pldistro ($NODEYUMEXCLUDE)"
92     for filein in $(find . -name '*.in') ; do
93         file=$(echo $filein | sed -e "s,\.in$,,")
94         sed -e "s,@NODEYUMEXCLUDE@,$NODEYUMEXCLUDE,g" $filein > $file
95     done
96     rm -f stock.repo
97     cat *.repo > stock.repo
98     popd
99 done
100 popd
101
102 echo "* nodeconfig/yum done $(date +%H-%M-%S)"
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106
107 ############################## node-side
108 pushd nodeimage
109 for out in *.tar *.tar.bz2 ; do
110     echo "* Installing $out"
111     install -D -m 644 $out $RPM_BUILD_ROOT/var/www/html/boot/$out
112 done
113 for out in *.sha1sum; do
114     echo "* Installing $out"
115     install -D -m 444 $out $RPM_BUILD_ROOT/var/www/html/boot/$out
116 done
117 popd
118
119 ############################## server-side
120 # ship all fcdistros for multi-fcdistros myplc, and let the php scripts do the right thing
121 pushd nodeimage
122 echo "* Installing MyPLC-side nodes yum config utilities (support for multi-fcdistro)"
123 mkdir -p $RPM_BUILD_ROOT/var/www/html/yum/
124 rsync -av ./nodeconfig/yum/     $RPM_BUILD_ROOT/var/www/html/yum/
125
126 # Install initscripts
127 echo "* Installing plc.d initscripts"
128 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
129 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
130
131 echo "* Installing db-config.d files"
132 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
133 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
134 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
135 popd
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140
141 %files
142 %defattr(-,root,root,-)
143 /var/www/html/boot/bootstrapfs*.tar.bz2
144 /var/www/html/boot/bootstrapfs*.tar.bz2.sha1sum
145
146 %files plain
147 %defattr(-,root,root,-)
148 /var/www/html/boot/bootstrapfs*.tar
149 /var/www/html/boot/bootstrapfs*.tar.sha1sum
150
151 %files -n nodeyum
152 %defattr(-,root,root,-)
153 /var/www/html/yum
154 /etc/planetlab/db-config.d
155 /etc/plc.d
156
157 %changelog
158 * Mon Jan 07 2019 Thierry <Parmentelat> - nodeimage-5.2-9
159 - ok for f27 and f29
160 - cleanup old distros
161
162 * Sun Jul 16 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-8
163 - fix the fedora and fedora-updates repo definitions for f25
164 - add /etc/plc.d/packages index
165
166 * Sun Jul 10 2016 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-7
167 - yum config ; deprecates old fedora releases, add support for f23/f24
168
169 * Fri Nov 13 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-6
170 - fix for f22 and dnf.conf
171
172 * Fri Jun 26 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-5
173 - the yum config for nodes on f21 and f22
174 - define a new config_file for /etc/dnf/dnf.conf so that /etc/yum.myplc.d
175 - is taken into account on f22
176
177 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-4
178 - minor change; start plc packages only at run-time, not build-time
179 - only available on systems that have systemctl
180
181 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-3
182 - template for f20 yum config
183
184 * Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-2
185 - more timestamps during build
186
187 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-1
188 - add support for f18 yum config
189
190 * Mon Feb 11 2013 Stephen Soltesz <soltesz@opentechinstitute.org> - nodeimage-2.1-4
191
192 * Mon Nov 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-2.1-3
193 - fix /etc/plc.d/packages for empty install dirs
194
195 * Fri Sep 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-2.1-2
196 - exclude slice repos when running plc.d/packages start
197
198 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-2.1-1
199 - renamed as nodeimage - works on both mainline and lxc
200
201 * Thu Feb 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-14
202 - changes needed for build with yumexcludes defined in a separate pkgs file
203
204 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-13
205 - plc.d/packages: rewrote comments about some corner cases where it fails
206 - plc.d/packages: marginally more robust
207
208 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-12
209 - minor tweak in plc.d/packages
210
211 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - bootstrapfs-2.0-11
212 - sl6 templates
213
214 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-10
215 - bugfix for multi-flavour deployments
216
217 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-9
218 - for multi-flavours : 'packages' step in plc.d now handles vserver links and related hacks in yumgroups
219
220 * Thu Jan 27 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-8
221 - no semantic change - attempt to speed up build
222
223 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-7
224 - yum repo template for f14 nodes
225 - tweaks the way /etc/plc.d/packages works
226
227 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootstrapFS-2.0-6
228 - add sha1sum
229 - module name changes
230
231 * Tue Apr 27 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootstrapFS-2.0-5
232 - support different flavours of vservers on nodes
233
234 * Mon Apr 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-4
235 - fix unmatched $ in URL svn keywords
236
237 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-3
238 - choice between various pldistros is not made at build time, but at run time
239 - relies on GetNodeFlavour to expose the node's fcdistro - requires PLCAPI-5.0-5
240 - in addition, the baseurl for the myplc repo is http:// and not https:// anymore
241 - the https method does not work on fedora 12, and GPG is used below anyway
242
243 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-2
244 - new slicerepo package for exposing stuff to slivers
245
246 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-1
247 - first working version of 5.0:
248 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
249 - nodefailiy is 3-fold with pldistro-fcdistro-arch
250 - new module nodeyum; first draft has the php scripts and conf_files for tweaking nodes yum config
251
252 * Mon Jan 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-11
253 - for building on fedora12
254
255 * Thu Oct 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-10
256 - cosmetic change in message at build-time
257
258 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-9
259 - can use groups in the pkgs file with +++ for space
260
261 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-8
262 - bugfix for when a .post script is not needed
263
264 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-7
265 - search post-install scripts (.post) in path (distro, then planetlab)
266 - mostly useful for externally-defined pldistros
267
268 * Thu Jan 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-6
269 - fix build bug when dealing with extensions
270
271 * Thu Dec 04 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-5
272 - optional package bootstrapfs-<pldiftr>-<arch>-plain comes with uncompressed images for faster tests
273
274 * Fri Nov 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-4
275 - cosmetic changes in build: displays duration, and shows up in summary
276
277 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-3
278 - Do not overwrite yumgroups.xml upon updates of noderepo
279
280 * Thu Jul 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-2
281 - uses the right yum.conf when building images
282
283 * Mon May 05 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-1
284 - rpm release tag does not need pldistro as it is already part of the rpm name
285
286 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-0.1-2 BootstrapFS-1.0-0
287 - naming scheme changed, tarball name now contains ''nodefamily'' as <pldistro>-<arch>
288 - new package named 'noderepo' allows to ship the full set of node rpms to another (arch) myplc
289
290 * Fri Jan 18 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-0.1-1 bootstrapfs-0.1-2
291 - search more carefully for alternate pkgs files
292 - handling of sysconfig/crontab and creation of site_admin reviewed
293 - (this tag is set with module-tag.py)
294
295 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
296 - Initial build.
297
298 %define module_current_branch 1.0