Setting tag nodeimage-2.1-1
[bootstrapfs.git] / nodeimage.spec
1 %define nodefamily %{pldistro}-%{distroname}-%{_arch}
2 %define extensionfamily %{distroname}-%{_arch}
3
4 %define name nodeimage-%{nodefamily}
5 %define version 2.1
6 %define taglevel 1
7
8 # pldistro already in the rpm name
9 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
10 %define release %{taglevel}%{?date:.%{date}}
11
12 # we don't really need the standard postinstall process from rpm that
13 # strips files and byte-compiles python files. all files in this
14 # package are comming from other rpm files and they've already went
15 # through this post install processing. - baris
16 %define __os_install_post %{nil}
17
18 Vendor: PlanetLab
19 Packager: PlanetLab Central <support@planet-lab.org>
20 Distribution: PlanetLab %{plrelease}
21 URL: %{SCMURL}
22
23 Summary: The PlanetLab nodeimage filesystems for %{nodefamily}
24 Name: %{name}
25 Version: %{version}
26 Release: %{release}
27 License: BSD
28 Group: System Environment/Base
29 Source0: %{name}-%{version}.tar.gz
30 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
31 # other archs must be able to install this
32 BuildArch: noarch
33
34 Requires: tar, gnupg, sharutils, bzip2
35 # this is for plc.d/packages that uses ed for hacking yumgroups.xml
36 Requires: ed
37
38 # 5.1 now uses new name nodeimage
39 Obsoletes: bootstrapfs-%{nodefamily}
40 # 5.0 now has 3-fold nodefamily
41 %define obsolete_nodefamily %{pldistro}-%{_arch}
42 Obsoletes: bootstrapfs-%{obsolete_nodefamily}
43
44 AutoReqProv: no
45 %define debug_package %{nil}
46
47 %description
48
49 The PlanetLab nodeimage filesystem is downloaded by the
50 BootManager to reinstall a node with a new filesystem.
51
52 %package plain
53 Summary: The (uncompressed) PlanetLab nodeimage filesystem for %{nodefamily}
54 Group: System Environment/Base
55 %description plain
56 This package provides the same functions as %{name} but with uncompressed tarball for faster tests.
57
58 %package -n nodeyum
59 Summary: the MyPLC-side utilities for tweaking nodes yum configs
60 Group: System Environment/Base
61 %description -n nodeyum 
62 Utility scripts for configuring node updates. This package is designed
63 for the MyPLC side.
64
65 %prep
66 %setup -q
67
68 %build
69
70 ############################## node-side
71 pushd nodeimage
72 ./build.sh %{pldistro} 
73 for tar in *.tar *.tar.bz2; do 
74    echo "* Computing SHA1 checksum for $tar"
75    sha1sum $tar > $tar.sha1sum
76    chmod 444 $tar.sha1sum
77 done
78 popd
79
80 ############################## server-side
81 # ship all fcdistros for multi-fcdistros myplc, and let the php scripts do the right thing
82 pushd nodeimage/nodeconfig/yum
83 # scan fcdistros and catenate all repos in 'stock.repo' so db-config can be distro-independant
84 for fcdistro in $(ls); do
85     [ -d $fcdistro ] || continue
86     # get packages to exclude on nodes for that fcdistro/pldistro
87     NODEYUMEXCLUDE="exclude=$(../../../build/nodeyumexclude.sh $fcdistro %{pldistro})"
88     pushd $fcdistro/yum.myplc.d
89     echo "* Handling NODEYUMEXCLUDE in yum repo for $fcdistro/$pldistro ($NODEYUMEXCLUDE)"
90     for filein in $(find . -name '*.in') ; do
91         file=$(echo $filein | sed -e "s,\.in$,,")
92         sed -e "s,@NODEYUMEXCLUDE@,$NODEYUMEXCLUDE,g" $filein > $file
93     done
94     rm -f stock.repo
95     cat *.repo > stock.repo
96     popd
97 done
98 popd
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 ############################## node-side
104 pushd nodeimage
105 for out in *.tar *.tar.bz2 ; do
106     echo "* Installing $out"
107     install -D -m 644 $out $RPM_BUILD_ROOT/var/www/html/boot/$out
108 done
109 for out in *.sha1sum; do
110     echo "* Installing $out"
111     install -D -m 444 $out $RPM_BUILD_ROOT/var/www/html/boot/$out
112 done
113 popd
114
115 ############################## server-side
116 # ship all fcdistros for multi-fcdistros myplc, and let the php scripts do the right thing
117 pushd nodeimage
118 echo "* Installing MyPLC-side nodes yum config utilities (support for multi-fcdistro)"
119 mkdir -p $RPM_BUILD_ROOT/var/www/html/yum/
120 rsync -av ./nodeconfig/yum/     $RPM_BUILD_ROOT/var/www/html/yum/
121
122 # Install initscripts
123 echo "* Installing plc.d initscripts"
124 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
125 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
126
127 echo "* Installing db-config.d files"
128 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
129 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
130 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
131 popd
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136
137 %files
138 %defattr(-,root,root,-)
139 /var/www/html/boot/bootstrapfs*.tar.bz2
140 /var/www/html/boot/bootstrapfs*.tar.bz2.sha1sum
141
142 %files plain
143 %defattr(-,root,root,-)
144 /var/www/html/boot/bootstrapfs*.tar
145 /var/www/html/boot/bootstrapfs*.tar.sha1sum
146
147 %files -n nodeyum
148 %defattr(-,root,root,-)
149 /var/www/html/yum
150 /etc/planetlab/db-config.d
151 /etc/plc.d
152
153 %changelog
154 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-2.1-1
155 - renamed as nodeimage - works on both mainline and lxc
156
157 * Thu Feb 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-14
158 - changes needed for build with yumexcludes defined in a separate pkgs file
159
160 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-13
161 - plc.d/packages: rewrote comments about some corner cases where it fails
162 - plc.d/packages: marginally more robust
163
164 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-12
165 - minor tweak in plc.d/packages
166
167 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - bootstrapfs-2.0-11
168 - sl6 templates
169
170 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-10
171 - bugfix for multi-flavour deployments
172
173 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-9
174 - for multi-flavours : 'packages' step in plc.d now handles vserver links and related hacks in yumgroups
175
176 * Thu Jan 27 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-8
177 - no semantic change - attempt to speed up build
178
179 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-7
180 - yum repo template for f14 nodes
181 - tweaks the way /etc/plc.d/packages works
182
183 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootstrapFS-2.0-6
184 - add sha1sum
185 - module name changes
186
187 * Tue Apr 27 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootstrapFS-2.0-5
188 - support different flavours of vservers on nodes
189
190 * Mon Apr 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-4
191 - fix unmatched $ in URL svn keywords
192
193 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-3
194 - choice between various pldistros is not made at build time, but at run time
195 - relies on GetNodeFlavour to expose the node's fcdistro - requires PLCAPI-5.0-5
196 - in addition, the baseurl for the myplc repo is http:// and not https:// anymore
197 - the https method does not work on fedora 12, and GPG is used below anyway
198
199 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-2
200 - new slicerepo package for exposing stuff to slivers
201
202 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-1
203 - first working version of 5.0:
204 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
205 - nodefailiy is 3-fold with pldistro-fcdistro-arch
206 - new module nodeyum; first draft has the php scripts and conf_files for tweaking nodes yum config
207
208 * Mon Jan 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-11
209 - for building on fedora12
210
211 * Thu Oct 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-10
212 - cosmetic change in message at build-time
213
214 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-9
215 - can use groups in the pkgs file with +++ for space
216
217 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-8
218 - bugfix for when a .post script is not needed
219
220 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-7
221 - search post-install scripts (.post) in path (distro, then planetlab)
222 - mostly useful for externally-defined pldistros
223
224 * Thu Jan 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-6
225 - fix build bug when dealing with extensions
226
227 * Thu Dec 04 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-5
228 - optional package bootstrapfs-<pldiftr>-<arch>-plain comes with uncompressed images for faster tests
229
230 * Fri Nov 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-4
231 - cosmetic changes in build: displays duration, and shows up in summary
232
233 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-3
234 - Do not overwrite yumgroups.xml upon updates of noderepo
235
236 * Thu Jul 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-2
237 - uses the right yum.conf when building images
238
239 * Mon May 05 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-1
240 - rpm release tag does not need pldistro as it is already part of the rpm name
241
242 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-0.1-2 BootstrapFS-1.0-0
243 - naming scheme changed, tarball name now contains ''nodefamily'' as <pldistro>-<arch>
244 - new package named 'noderepo' allows to ship the full set of node rpms to another (arch) myplc
245
246 * Fri Jan 18 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-0.1-1 bootstrapfs-0.1-2
247 - search more carefully for alternate pkgs files
248 - handling of sysconfig/crontab and creation of site_admin reviewed
249 - (this tag is set with module-tag.py)
250
251 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
252 - Initial build.
253
254 %define module_current_branch 1.0