Setting tag BootstrapFS-1.0-10
[bootstrapfs.git] / noderepo.spec
1 #
2 # $Id$
3 #
4 %define url $URL: svn+ssh://thierry@svn.planet-lab.org/svn/BootstrapFS/trunk/bootstrapfs.spec $
5
6 # build is expected to export the following rpm variables
7 # %{distroname}     : e.g. Fedora
8 # %{distrorelease}  : e.g. 8
9 # %{node_rpms_plus} : as a +++ separated list of rpms from the build dir
10
11 %define nodefamily %{pldistro}-%{_arch}
12
13 %define name noderepo-%{nodefamily}
14 %define version 1.0
15 %define taglevel 10
16
17 # pldistro already in the rpm name
18 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
19 %define release %{taglevel}%{?date:.%{date}}
20
21 Vendor: PlanetLab
22 Packager: PlanetLab Central <support@planet-lab.org>
23 Distribution: PlanetLab %{plrelease}
24 URL: %(echo %{url} | cut -d ' ' -f 2)
25
26 Summary: The initial content of the yum repository for nodes
27 Name: %{name}
28 Version: %{version}
29 Release: %{release}
30 License: BSD
31 Group: System Environment/Base
32 Source0: %{name}-%{version}.tar.gz
33 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
34 # other archs must be able to install this
35 BuildArch: noarch
36
37 BuildRequires: rsync 
38 Requires: myplc
39
40 %define debug_package %{nil}
41
42 %description
43 This rpm contains all the rpms designed for running on a PlanetLab node
44 they come organized into a yum repository 
45
46 %prep
47 %setup -q
48
49 %build
50 echo nothing to do at build time for noderepo
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 repo=%{nodefamily}
56 install -d -m 755 $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo
57 rpms=$(echo %{node_rpms_plus} | sed -e 's,+++, ,g')
58 for rpm in $rpms; do rsync %{_topdir}/$rpm $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo/ ; done
59 ### yumgroups
60 install -D -m 644 %{_topdir}/RPMS/yumgroups.xml $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo/yumgroups.xml
61 # do not do this yet, as plc.d/packages will do it anyway
62 #createrepo -g yumgroups.xml $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %post
68 service plc start packages
69
70 %files
71 %defattr(-,root,root,-)
72 /var/www/html/install-rpms/%{nodefamily}
73 # don't overwrite yumgroups.xml if exists
74 %config(noreplace) /var/www/html/install-rpms/%{nodefamily}/yumgroups.xml
75
76 %changelog
77 * Thu Oct 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-10
78 - cosmetic change in message at build-time
79
80 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-9
81 - can use groups in the pkgs file with +++ for space
82
83 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-8
84 - bugfix for when a .post script is not needed
85
86 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-7
87 - search post-install scripts (.post) in path (distro, then planetlab)
88 - mostly useful for externally-defined pldistros
89
90 * Thu Jan 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-6
91 - fix build bug when dealing with extensions
92
93 * Thu Dec 04 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-5
94 - optional package bootstrapfs-<pldiftr>-<arch>-plain comes with uncompressed images for faster tests
95
96 * Fri Nov 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-4
97 - cosmetic changes in build: displays duration, and shows up in summary
98
99 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-3
100 - Do not overwrite yumgroups.xml upon updates of noderepo
101
102 * Thu Jul 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-2
103 - uses the right yum.conf when building images
104
105 * Mon May 05 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-1
106 - rpm release tag does not need pldistro as it is already part of the rpm name
107
108 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-0.1-2 BootstrapFS-1.0-0
109 - naming scheme changed, tarball name now contains ''nodefamily'' as <pldistro>-<arch>
110 - new package named 'noderepo' allows to ship the full set of node rpms to another (arch) myplc
111
112 * Tue Mar 4 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> -
113 - Initial build.