fix
[bootstrapfs.git] / noderepo.spec
1 #
2 # $Id: bootstrapfs.spec 7668 2008-01-08 11:49:43Z thierry $
3 #
4 %define url $URL: svn+ssh://thierry@svn.planet-lab.org/svn/BootstrapFS/trunk/bootstrapfs.spec $
5
6 # build is expected to export the following rpm variables
7 # %{distroname}     : e.g. Fedora
8 # %{distrorelease}  : e.g. 8
9 # %{node_rpms_plus} : as a +++ separated list of rpms from the build dir
10
11 %define nodetype %{pldistro}%{distroname}%{_arch}
12
13 %define name noderepo-%{nodetype}
14 %define version 4.2
15 %define taglevel 1
16
17 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %(echo %{url} | cut -d ' ' -f 2)
23
24 Summary: The initial content of the yum repository for nodes
25 Name: %{name}
26 Version: %{version}
27 Release: %{release}
28 License: BSD
29 Group: System Environment/Base
30 Source0: %{name}-%{version}.tar.gz
31 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
32
33 BuildRequires: rsync createrepo
34 Requires: myplc
35
36 %define debug_package %{nil}
37
38 %description
39 This rpm contains all the rpms designed for running on a PlanetLab node
40 they come organized into a yum repository 
41
42 %prep
43 %setup -q
44
45 %build
46 echo nothing to do at build time for noderepo
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 repo=%{nodetype}
52 install -d -m 755 $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo
53 rpms=$(echo %{node_rpms_plus} | sed -e 's,+++, ,g')
54 for rpm in $rpms; do rsync %{_topdir}/$rpm $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo/ ; done
55 ### yumgroups
56 install -D -m 644 %{_topdir}/RPMS/yumgroups.xml $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo
57 createrepo -g yumgroups.xml $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %post
63 service plc start packages
64
65 %files
66 %defattr(-,root,root,-)
67 /var/www/html/install-rpms/%{nodetype}
68
69 %changelog
70 * Tue Mar 4 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> -
71 - Initial build.