Setting tag nodeimage-5.2-7
[bootstrapfs.git] / noderepo.spec
1 # build is expected to export the following rpm variables
2 # %{distroname}     : e.g. Fedora
3 # %{distrorelease}  : e.g. 8
4 # %{node_rpms_plus} : as a +++ separated list of rpms from the build dir
5
6 %define nodefamily %{pldistro}-%{distroname}-%{_arch}
7 %define obsolete_nodefamily %{pldistro}-%{_arch}
8
9 %define name noderepo-%{nodefamily}
10 %define version 5.2
11 %define taglevel 7
12
13 # pldistro already in the rpm name
14 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
15 %define release %{taglevel}%{?date:.%{date}}
16
17 # we don't really need the standard postinstall process from rpm that
18 # strips files and byte-compiles python files. all files in this
19 # package are comming from other rpm files and they've already went
20 # through this post install processing. - baris
21 %define __os_install_post %{nil}
22
23 Vendor: OneLab
24 Packager: PlanetLab Europe <build@onelab.eu>
25 Distribution: PlanetLab %{plrelease}
26 URL: %{SCMURL}
27
28 Summary: The yum repository for nodes, to be installed on the myplc-side
29 Name: %{name}
30 Version: %{version}
31 Release: %{release}
32 License: BSD
33 Group: System Environment/Base
34 Source0: %{name}-%{version}.tar.gz
35 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
36 # other archs must be able to install this
37 BuildArch: noarch
38
39 BuildRequires: rsync 
40 Requires: myplc
41
42 # 5.0 now has 3-fold nodefamily
43 %define obsolete_nodefamily %{pldistro}-%{_arch}
44 Obsoletes: noderepo-%{obsolete_nodefamily}
45
46 %define debug_package %{nil}
47
48 %description
49 This rpm contains all the rpms designed for running on a PlanetLab node
50 they come organized into a yum repository 
51
52 %prep
53 %setup -q
54
55 %build
56 echo nothing to do at build time for noderepo
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 repo=%{nodefamily}
62 install -d -m 755 $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo
63 rpms=$(echo %{node_rpms_plus} | sed -e 's,+++, ,g')
64 for rpm in $rpms; do rsync %{_topdir}/$rpm $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo/ ; done
65 ### yumgroups
66 install -D -m 644 %{_topdir}/RPMS/yumgroups.xml $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo/yumgroups.xml
67 # do not do this yet, as plc.d/packages will do it anyway
68 #createrepo -g yumgroups.xml $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %post
74 # it would at first glance seem to make sense to invoke service plc start gpg here as well, 
75 # as noderepo might get installed before myplc gets even started 
76 # this however exhibit a deadlock, as rpm --almatches -e gpg-pubkey waits for transaction lock
77 # that is help by the calling yum/rpm
78 if [ ! -e /bin/systemctl ] ; then
79    echo "Systemd is not there. Just starting PLC to handle packages (may fail if PLC is not configured) ..."
80    service plc start packages
81 elif /bin/systemctl status plc >/dev/null ; then
82    echo "Restarting PLC to handle packages ..."
83    service plc restart packages
84 else
85    echo "PLC is not running. Skipping a restart ..."
86 fi
87
88 %files
89 %defattr(-,root,root,-)
90 /var/www/html/install-rpms/%{nodefamily}
91 # don't overwrite yumgroups.xml if exists
92 %config(noreplace) /var/www/html/install-rpms/%{nodefamily}/yumgroups.xml
93
94 %changelog
95 * Sun Jul 10 2016 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-7
96 - yum config ; deprecates old fedora releases, add support for f23/f24
97
98 * Fri Nov 13 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-6
99 - fix for f22 and dnf.conf
100
101 * Fri Jun 26 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-5
102 - the yum config for nodes on f21 and f22
103 - define a new config_file for /etc/dnf/dnf.conf so that /etc/yum.myplc.d
104 - is taken into account on f22
105
106 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-4
107 - minor change; start plc packages only at run-time, not build-time
108 - only available on systems that have systemctl
109
110 * Tue Jul 22 2014 Thomas Dreibholz <dreibh@simula.no> - nodeimage-5.2-4
111 - Post-install fix: trying to start PLC only when it is running, in order to avoid false-positive error message during build.
112
113 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-3
114 - template for f20 yum config
115
116 * Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-2
117 - more timestamps during build
118
119 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-1
120 - add support for f18 yum config
121
122 * Mon Feb 11 2013 Stephen Soltesz <soltesz@opentechinstitute.org> - nodeimage-2.1-4
123
124 * Mon Nov 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-2.1-3
125 - fix /etc/plc.d/packages for empty install dirs
126
127 * Fri Sep 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-2.1-2
128 - exclude slice repos when running plc.d/packages start
129
130 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-2.1-1
131 - renamed as nodeimage - works on both mainline and lxc
132
133 * Thu Feb 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-14
134 - changes needed for build with yumexcludes defined in a separate pkgs file
135
136 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-13
137 - plc.d/packages: rewrote comments about some corner cases where it fails
138 - plc.d/packages: marginally more robust
139
140 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-12
141 - minor tweak in plc.d/packages
142
143 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - bootstrapfs-2.0-11
144 - sl6 templates
145
146 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-10
147 - bugfix for multi-flavour deployments
148
149 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-9
150 - for multi-flavours : 'packages' step in plc.d now handles vserver links and related hacks in yumgroups
151
152 * Thu Jan 27 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-8
153 - no semantic change - attempt to speed up build
154
155 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-7
156 - yum repo template for f14 nodes
157 - tweaks the way /etc/plc.d/packages works
158
159 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootstrapFS-2.0-6
160 - add sha1sum
161 - module name changes
162
163 * Tue Apr 27 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootstrapFS-2.0-5
164 - support different flavours of vservers on nodes
165
166 * Mon Apr 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-4
167 - fix unmatched $ in URL svn keywords
168
169 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-3
170 - choice between various pldistros is not made at build time, but at run time
171 - relies on GetNodeFlavour to expose the node's fcdistro - requires PLCAPI-5.0-5
172 - in addition, the baseurl for the myplc repo is http:// and not https:// anymore
173 - the https method does not work on fedora 12, and GPG is used below anyway
174
175 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-2
176 - new slicerepo package for exposing stuff to slivers
177
178 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-1
179 - first working version of 5.0:
180 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
181 - nodefailiy is 3-fold with pldistro-fcdistro-arch
182 - new module nodeyum; first draft has the php scripts and conf_files for tweaking nodes yum config
183
184 * Mon Jan 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-11
185 - for building on fedora12
186
187 * Thu Oct 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-10
188 - cosmetic change in message at build-time
189
190 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-9
191 - can use groups in the pkgs file with +++ for space
192
193 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-8
194 - bugfix for when a .post script is not needed
195
196 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-7
197 - search post-install scripts (.post) in path (distro, then planetlab)
198 - mostly useful for externally-defined pldistros
199
200 * Thu Jan 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-6
201 - fix build bug when dealing with extensions
202
203 * Thu Dec 04 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-5
204 - optional package bootstrapfs-<pldiftr>-<arch>-plain comes with uncompressed images for faster tests
205
206 * Fri Nov 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-4
207 - cosmetic changes in build: displays duration, and shows up in summary
208
209 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-3
210 - Do not overwrite yumgroups.xml upon updates of noderepo
211
212 * Thu Jul 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-2
213 - uses the right yum.conf when building images
214
215 * Mon May 05 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-1
216 - rpm release tag does not need pldistro as it is already part of the rpm name
217
218 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-0.1-2 BootstrapFS-1.0-0
219 - naming scheme changed, tarball name now contains ''nodefamily'' as <pldistro>-<arch>
220 - new package named 'noderepo' allows to ship the full set of node rpms to another (arch) myplc
221
222 * Tue Mar 4 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> -
223 - Initial build.
224
225 %define module_current_branch 1.0