oops - fix numbers
[bootstrapfs.git] / noderepo.spec
1 # build is expected to export the following rpm variables
2 # %{distroname}     : e.g. Fedora
3 # %{distrorelease}  : e.g. 8
4 # %{node_rpms_plus} : as a +++ separated list of rpms from the build dir
5
6 %define nodefamily %{pldistro}-%{distroname}-%{_arch}
7 %define obsolete_nodefamily %{pldistro}-%{_arch}
8
9 %define name noderepo-%{nodefamily}
10 %define version 2.1
11 %define taglevel 0
12
13 # pldistro already in the rpm name
14 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
15 %define release %{taglevel}%{?date:.%{date}}
16
17 # we don't really need the standard postinstall process from rpm that
18 # strips files and byte-compiles python files. all files in this
19 # package are comming from other rpm files and they've already went
20 # through this post install processing. - baris
21 %define __os_install_post %{nil}
22
23 Vendor: OneLab
24 Packager: PlanetLab Europe <build@onelab.eu>
25 Distribution: PlanetLab %{plrelease}
26 URL: %{SCMURL}
27
28 Summary: The yum repository for nodes, to be installed on the myplc-side
29 Name: %{name}
30 Version: %{version}
31 Release: %{release}
32 License: BSD
33 Group: System Environment/Base
34 Source0: %{name}-%{version}.tar.gz
35 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
36 # other archs must be able to install this
37 BuildArch: noarch
38
39 BuildRequires: rsync 
40 Requires: myplc
41
42 # 5.0 now has 3-fold nodefamily
43 %define obsolete_nodefamily %{pldistro}-%{_arch}
44 Obsoletes: noderepo-%{obsolete_nodefamily}
45
46 %define debug_package %{nil}
47
48 %description
49 This rpm contains all the rpms designed for running on a PlanetLab node
50 they come organized into a yum repository 
51
52 %prep
53 %setup -q
54
55 %build
56 echo nothing to do at build time for noderepo
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 repo=%{nodefamily}
62 install -d -m 755 $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo
63 rpms=$(echo %{node_rpms_plus} | sed -e 's,+++, ,g')
64 for rpm in $rpms; do rsync %{_topdir}/$rpm $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo/ ; done
65 ### yumgroups
66 install -D -m 644 %{_topdir}/RPMS/yumgroups.xml $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo/yumgroups.xml
67 # do not do this yet, as plc.d/packages will do it anyway
68 #createrepo -g yumgroups.xml $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %post
74 # it would at first glance seem to make sense to invoke service plc start gpg here as well, 
75 # as noderepo might get installed before myplc gets even started 
76 # this however exhibit a deadlock, as rpm --almatches -e gpg-pubkey waits for transaction lock
77 # that is help by the calling yum/rpm
78 service plc start packages
79
80 %files
81 %defattr(-,root,root,-)
82 /var/www/html/install-rpms/%{nodefamily}
83 # don't overwrite yumgroups.xml if exists
84 %config(noreplace) /var/www/html/install-rpms/%{nodefamily}/yumgroups.xml
85
86 %changelog
87 * Thu Feb 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-14
88 - changes needed for build with yumexcludes defined in a separate pkgs file
89
90 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-13
91 - plc.d/packages: rewrote comments about some corner cases where it fails
92 - plc.d/packages: marginally more robust
93
94 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-12
95 - minor tweak in plc.d/packages
96
97 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - bootstrapfs-2.0-11
98 - sl6 templates
99
100 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-10
101 - bugfix for multi-flavour deployments
102
103 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-9
104 - for multi-flavours : 'packages' step in plc.d now handles vserver links and related hacks in yumgroups
105
106 * Thu Jan 27 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-8
107 - no semantic change - attempt to speed up build
108
109 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-7
110 - yum repo template for f14 nodes
111 - tweaks the way /etc/plc.d/packages works
112
113 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootstrapFS-2.0-6
114 - add sha1sum
115 - module name changes
116
117 * Tue Apr 27 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootstrapFS-2.0-5
118 - support different flavours of vservers on nodes
119
120 * Mon Apr 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-4
121 - fix unmatched $ in URL svn keywords
122
123 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-3
124 - choice between various pldistros is not made at build time, but at run time
125 - relies on GetNodeFlavour to expose the node's fcdistro - requires PLCAPI-5.0-5
126 - in addition, the baseurl for the myplc repo is http:// and not https:// anymore
127 - the https method does not work on fedora 12, and GPG is used below anyway
128
129 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-2
130 - new slicerepo package for exposing stuff to slivers
131
132 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-1
133 - first working version of 5.0:
134 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
135 - nodefailiy is 3-fold with pldistro-fcdistro-arch
136 - new module nodeyum; first draft has the php scripts and conf_files for tweaking nodes yum config
137
138 * Mon Jan 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-11
139 - for building on fedora12
140
141 * Thu Oct 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-10
142 - cosmetic change in message at build-time
143
144 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-9
145 - can use groups in the pkgs file with +++ for space
146
147 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-8
148 - bugfix for when a .post script is not needed
149
150 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-7
151 - search post-install scripts (.post) in path (distro, then planetlab)
152 - mostly useful for externally-defined pldistros
153
154 * Thu Jan 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-6
155 - fix build bug when dealing with extensions
156
157 * Thu Dec 04 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-5
158 - optional package bootstrapfs-<pldiftr>-<arch>-plain comes with uncompressed images for faster tests
159
160 * Fri Nov 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-4
161 - cosmetic changes in build: displays duration, and shows up in summary
162
163 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-3
164 - Do not overwrite yumgroups.xml upon updates of noderepo
165
166 * Thu Jul 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-2
167 - uses the right yum.conf when building images
168
169 * Mon May 05 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-1
170 - rpm release tag does not need pldistro as it is already part of the rpm name
171
172 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-0.1-2 BootstrapFS-1.0-0
173 - naming scheme changed, tarball name now contains ''nodefamily'' as <pldistro>-<arch>
174 - new package named 'noderepo' allows to ship the full set of node rpms to another (arch) myplc
175
176 * Tue Mar 4 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> -
177 - Initial build.
178
179 %define module_current_branch 1.0