check consistency of specfiles:
[bootstrapfs.git] / noderepo.spec
1 #
2 # $Id: bootstrapfs.spec 7668 2008-01-08 11:49:43Z thierry $
3 #
4 %define url $URL: svn+ssh://thierry@svn.planet-lab.org/svn/BootstrapFS/trunk/bootstrapfs.spec $
5
6 # build is expected to export the following rpm variables
7 # %{distroname}     : e.g. Fedora
8 # %{distrorelease}  : e.g. 8
9 # %{node_rpms_plus} : as a +++ separated list of rpms from the build dir
10
11 %define nodefamily %{pldistro}-%{_arch}
12
13 %define name noderepo-%{nodefamily}
14 %define version 1.0
15 %define taglevel 0
16
17 # pldistro already in the rpm name
18 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
19 %define release %{taglevel}%{?date:.%{date}}
20
21 Vendor: PlanetLab
22 Packager: PlanetLab Central <support@planet-lab.org>
23 Distribution: PlanetLab %{plrelease}
24 URL: %(echo %{url} | cut -d ' ' -f 2)
25
26 Summary: The initial content of the yum repository for nodes
27 Name: %{name}
28 Version: %{version}
29 Release: %{release}
30 License: BSD
31 Group: System Environment/Base
32 Source0: %{name}-%{version}.tar.gz
33 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
34 # other archs must be able to install this
35 BuildArch: noarch
36
37 BuildRequires: rsync 
38 Requires: myplc
39
40 %define debug_package %{nil}
41
42 %description
43 This rpm contains all the rpms designed for running on a PlanetLab node
44 they come organized into a yum repository 
45
46 %prep
47 %setup -q
48
49 %build
50 echo nothing to do at build time for noderepo
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 repo=%{nodefamily}
56 install -d -m 755 $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo
57 rpms=$(echo %{node_rpms_plus} | sed -e 's,+++, ,g')
58 for rpm in $rpms; do rsync %{_topdir}/$rpm $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo/ ; done
59 ### yumgroups
60 install -D -m 644 %{_topdir}/RPMS/yumgroups.xml $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo/yumgroups.xml
61 # do not do this yet, as plc.d/packages will do it anyway
62 #createrepo -g yumgroups.xml $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %post
68 service plc start packages
69
70 %files
71 %defattr(-,root,root,-)
72 /var/www/html/install-rpms/%{nodefamily}
73
74 %changelog
75 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-0.1-2 BootstrapFS-1.0-0
76 - naming scheme changed, tarball name now contains ''nodefamily'' as <pldistro>-<arch>
77 - new package named 'noderepo' allows to ship the full set of node rpms to another (arch) myplc
78
79 * Tue Mar 4 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> -
80 - Initial build.