Setting tag nodeimage-5.2-8
[bootstrapfs.git] / noderepo.spec
1 # build is expected to export the following rpm variables
2 # %{distroname}     : e.g. Fedora
3 # %{distrorelease}  : e.g. 8
4 # %{node_rpms_plus} : as a +++ separated list of rpms from the build dir
5
6 %define nodefamily %{pldistro}-%{distroname}-%{_arch}
7 %define obsolete_nodefamily %{pldistro}-%{_arch}
8
9 %define name noderepo-%{nodefamily}
10 %define version 5.2
11 %define taglevel 8
12
13 # pldistro already in the rpm name
14 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
15 %define release %{taglevel}%{?date:.%{date}}
16
17 # we don't really need the standard postinstall process from rpm that
18 # strips files and byte-compiles python files. all files in this
19 # package are comming from other rpm files and they've already went
20 # through this post install processing. - baris
21 %define __os_install_post %{nil}
22
23 Vendor: OneLab
24 Packager: PlanetLab Europe <build@onelab.eu>
25 Distribution: PlanetLab %{plrelease}
26 URL: %{SCMURL}
27
28 Summary: The yum repository for nodes, to be installed on the myplc-side
29 Name: %{name}
30 Version: %{version}
31 Release: %{release}
32 License: BSD
33 Group: System Environment/Base
34 Source0: %{name}-%{version}.tar.gz
35 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
36 # other archs must be able to install this
37 BuildArch: noarch
38
39 BuildRequires: rsync 
40 Requires: myplc
41
42 # 5.0 now has 3-fold nodefamily
43 %define obsolete_nodefamily %{pldistro}-%{_arch}
44 Obsoletes: noderepo-%{obsolete_nodefamily}
45
46 %define debug_package %{nil}
47
48 %description
49 This rpm contains all the rpms designed for running on a PlanetLab node
50 they come organized into a yum repository 
51
52 %prep
53 %setup -q
54
55 %build
56 echo nothing to do at build time for noderepo
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 repo=%{nodefamily}
62 install -d -m 755 $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo
63 rpms=$(echo %{node_rpms_plus} | sed -e 's,+++, ,g')
64 for rpm in $rpms; do rsync %{_topdir}/$rpm $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo/ ; done
65 ### yumgroups
66 install -D -m 644 %{_topdir}/RPMS/yumgroups.xml $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo/yumgroups.xml
67 # do not do this yet, as plc.d/packages will do it anyway
68 #createrepo -g yumgroups.xml $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %post
74 # it would at first glance seem to make sense to invoke service plc start gpg here as well, 
75 # as noderepo might get installed before myplc gets even started 
76 # this however exhibit a deadlock, as rpm --almatches -e gpg-pubkey waits for transaction lock
77 # that is help by the calling yum/rpm
78 if [ ! -e /bin/systemctl ] ; then
79    echo "Systemd is not there. Just starting PLC to handle packages (may fail if PLC is not configured) ..."
80    service plc start packages
81 elif /bin/systemctl status plc >/dev/null ; then
82    echo "Restarting PLC to handle packages ..."
83    service plc restart packages
84 else
85    echo "PLC is not running. Skipping a restart ..."
86 fi
87
88 %files
89 %defattr(-,root,root,-)
90 /var/www/html/install-rpms/%{nodefamily}
91 # don't overwrite yumgroups.xml if exists
92 %config(noreplace) /var/www/html/install-rpms/%{nodefamily}/yumgroups.xml
93
94 %changelog
95 * Sun Jul 16 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-8
96 - fix the fedora and fedora-updates repo definitions for f25
97 - add /etc/plc.d/packages index
98
99 * Sun Jul 10 2016 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-7
100 - yum config ; deprecates old fedora releases, add support for f23/f24
101
102 * Fri Nov 13 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-6
103 - fix for f22 and dnf.conf
104
105 * Fri Jun 26 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-5
106 - the yum config for nodes on f21 and f22
107 - define a new config_file for /etc/dnf/dnf.conf so that /etc/yum.myplc.d
108 - is taken into account on f22
109
110 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-4
111 - minor change; start plc packages only at run-time, not build-time
112 - only available on systems that have systemctl
113
114 * Tue Jul 22 2014 Thomas Dreibholz <dreibh@simula.no> - nodeimage-5.2-4
115 - Post-install fix: trying to start PLC only when it is running, in order to avoid false-positive error message during build.
116
117 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-3
118 - template for f20 yum config
119
120 * Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-2
121 - more timestamps during build
122
123 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-1
124 - add support for f18 yum config
125
126 * Mon Feb 11 2013 Stephen Soltesz <soltesz@opentechinstitute.org> - nodeimage-2.1-4
127
128 * Mon Nov 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-2.1-3
129 - fix /etc/plc.d/packages for empty install dirs
130
131 * Fri Sep 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-2.1-2
132 - exclude slice repos when running plc.d/packages start
133
134 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-2.1-1
135 - renamed as nodeimage - works on both mainline and lxc
136
137 * Thu Feb 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-14
138 - changes needed for build with yumexcludes defined in a separate pkgs file
139
140 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-13
141 - plc.d/packages: rewrote comments about some corner cases where it fails
142 - plc.d/packages: marginally more robust
143
144 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-12
145 - minor tweak in plc.d/packages
146
147 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - bootstrapfs-2.0-11
148 - sl6 templates
149
150 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-10
151 - bugfix for multi-flavour deployments
152
153 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-9
154 - for multi-flavours : 'packages' step in plc.d now handles vserver links and related hacks in yumgroups
155
156 * Thu Jan 27 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-8
157 - no semantic change - attempt to speed up build
158
159 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-7
160 - yum repo template for f14 nodes
161 - tweaks the way /etc/plc.d/packages works
162
163 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootstrapFS-2.0-6
164 - add sha1sum
165 - module name changes
166
167 * Tue Apr 27 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootstrapFS-2.0-5
168 - support different flavours of vservers on nodes
169
170 * Mon Apr 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-4
171 - fix unmatched $ in URL svn keywords
172
173 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-3
174 - choice between various pldistros is not made at build time, but at run time
175 - relies on GetNodeFlavour to expose the node's fcdistro - requires PLCAPI-5.0-5
176 - in addition, the baseurl for the myplc repo is http:// and not https:// anymore
177 - the https method does not work on fedora 12, and GPG is used below anyway
178
179 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-2
180 - new slicerepo package for exposing stuff to slivers
181
182 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-1
183 - first working version of 5.0:
184 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
185 - nodefailiy is 3-fold with pldistro-fcdistro-arch
186 - new module nodeyum; first draft has the php scripts and conf_files for tweaking nodes yum config
187
188 * Mon Jan 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-11
189 - for building on fedora12
190
191 * Thu Oct 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-10
192 - cosmetic change in message at build-time
193
194 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-9
195 - can use groups in the pkgs file with +++ for space
196
197 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-8
198 - bugfix for when a .post script is not needed
199
200 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-7
201 - search post-install scripts (.post) in path (distro, then planetlab)
202 - mostly useful for externally-defined pldistros
203
204 * Thu Jan 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-6
205 - fix build bug when dealing with extensions
206
207 * Thu Dec 04 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-5
208 - optional package bootstrapfs-<pldiftr>-<arch>-plain comes with uncompressed images for faster tests
209
210 * Fri Nov 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-4
211 - cosmetic changes in build: displays duration, and shows up in summary
212
213 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-3
214 - Do not overwrite yumgroups.xml upon updates of noderepo
215
216 * Thu Jul 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-2
217 - uses the right yum.conf when building images
218
219 * Mon May 05 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-1
220 - rpm release tag does not need pldistro as it is already part of the rpm name
221
222 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-0.1-2 BootstrapFS-1.0-0
223 - naming scheme changed, tarball name now contains ''nodefamily'' as <pldistro>-<arch>
224 - new package named 'noderepo' allows to ship the full set of node rpms to another (arch) myplc
225
226 * Tue Mar 4 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> -
227 - Initial build.
228
229 %define module_current_branch 1.0