Setting tag bootstrapfs-2.0-7
[bootstrapfs.git] / slicerepo.spec
1 # build is expected to export the following rpm variables
2 # %{distroname}     : e.g. Fedora
3 # %{distrorelease}  : e.g. 8
4 # %{slice_rpms_plus} : as a +++ separated list of rpms from the build dir
5
6 %define nodefamily %{pldistro}-%{distroname}-%{_arch}
7 %define obsolete_nodefamily %{pldistro}-%{_arch}
8
9 %define name slicerepo-%{nodefamily}
10 %define version 2.0
11 %define taglevel 7
12
13 # pldistro already in the rpm name
14 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
15 %define release %{taglevel}%{?date:.%{date}}
16
17 Vendor: OneLab
18 Packager: PlanetLab Europe <build@onelab.eu>
19 Distribution: PlanetLab %{plrelease}
20 URL: %{SCMURL}
21
22 Summary: The yum repository for slices, to be installed on the myplc-side
23 Name: %{name}
24 Version: %{version}
25 Release: %{release}
26 License: BSD
27 Group: System Environment/Base
28 Source0: %{name}-%{version}.tar.gz
29 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
30 # other archs must be able to install this
31 BuildArch: noarch
32
33 BuildRequires: rsync 
34 Requires: myplc
35
36 %define debug_package %{nil}
37
38 %description
39 This rpm contains all the rpms that might ship on a sliver image
40 they come organized into a yum repository 
41
42 %prep
43 %setup -q
44
45 %build
46 echo nothing to do at build time for slicerepo
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 repo=slice-%{nodefamily}
52 install -d -m 755 $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo
53 rpms=$(echo %{slice_rpms_plus} | sed -e 's,+++, ,g')
54 for rpm in $rpms; do rsync %{_topdir}/$rpm $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo/ ; done
55 ### yumgroups
56 install -D -m 644 %{_topdir}/RPMS/yumgroups.xml $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo/yumgroups.xml
57 # do not do this yet, as plc.d/packages will do it anyway
58 #createrepo -g yumgroups.xml $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %post
64 service plc start packages
65
66 %files
67 %defattr(-,root,root,-)
68 /var/www/html/install-rpms/slice-%{nodefamily}
69 # don't overwrite yumgroups.xml if exists
70 %config(noreplace) /var/www/html/install-rpms/slice-%{nodefamily}/yumgroups.xml
71
72 %changelog
73 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-7
74 - yum repo template for f14 nodes
75 - tweaks the way /etc/plc.d/packages works
76
77 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootstrapFS-2.0-6
78 - add sha1sum
79 - module name changes
80
81 * Tue Apr 27 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootstrapFS-2.0-5
82 - support different flavours of vservers on nodes
83
84 * Mon Apr 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-4
85 - fix unmatched $ in URL svn keywords
86
87 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-3
88 - choice between various pldistros is not made at build time, but at run time
89 - relies on GetNodeFlavour to expose the node's fcdistro - requires PLCAPI-5.0-5
90 - in addition, the baseurl for the myplc repo is http:// and not https:// anymore
91 - the https method does not work on fedora 12, and GPG is used below anyway
92
93 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-2
94 - new slicerepo package for exposing stuff to slivers
95