Setting tag nodeimage-5.2-6
[bootstrapfs.git] / slicerepo.spec
1 # build is expected to export the following rpm variables
2 # %{distroname}     : e.g. Fedora
3 # %{distrorelease}  : e.g. 8
4 # %{slice_rpms_plus} : as a +++ separated list of rpms from the build dir
5
6 %define nodefamily %{pldistro}-%{distroname}-%{_arch}
7 %define obsolete_nodefamily %{pldistro}-%{_arch}
8
9 %define name slicerepo-%{nodefamily}
10 %define version 5.2
11 %define taglevel 6
12
13 # pldistro already in the rpm name
14 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
15 %define release %{taglevel}%{?date:.%{date}}
16
17 # we don't really need the standard postinstall process from rpm that
18 # strips files and byte-compiles python files. all files in this
19 # package are comming from other rpm files and they've already went
20 # through this post install processing. - baris
21 %define __os_install_post %{nil}
22
23 Vendor: OneLab
24 Packager: PlanetLab Europe <build@onelab.eu>
25 Distribution: PlanetLab %{plrelease}
26 URL: %{SCMURL}
27
28 Summary: The yum repository for slices, to be installed on the myplc-side
29 Name: %{name}
30 Version: %{version}
31 Release: %{release}
32 License: BSD
33 Group: System Environment/Base
34 Source0: %{name}-%{version}.tar.gz
35 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
36 # other archs must be able to install this
37 BuildArch: noarch
38
39 BuildRequires: rsync 
40 Requires: myplc
41
42 %define debug_package %{nil}
43
44 %description
45 This rpm contains all the rpms that might ship on a sliver image
46 they come organized into a yum repository 
47
48 %prep
49 %setup -q
50
51 %build
52 echo nothing to do at build time for slicerepo
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 repo=slice-%{nodefamily}
58 install -d -m 755 $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo
59 rpms=$(echo %{slice_rpms_plus} | sed -e 's,+++, ,g')
60 for rpm in $rpms; do rsync %{_topdir}/$rpm $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo/ ; done
61 ### yumgroups
62 install -D -m 644 %{_topdir}/RPMS/yumgroups.xml $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo/yumgroups.xml
63 # do not do this yet, as plc.d/packages will do it anyway
64 #createrepo -g yumgroups.xml $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %post
70 if [ ! -e /bin/systemctl ] ; then
71    echo "Systemd is not there. Just starting PLC to handle packages (may fail of PLC is not configured) ..."
72    service plc start packages
73 elif /bin/systemctl status plc >/dev/null ; then
74    echo "Restarting PLC to handle packages ..."
75    service plc restart packages
76 else
77    echo "The PLC is not running. Skipping a restart ..."
78 fi
79
80 %files
81 %defattr(-,root,root,-)
82 /var/www/html/install-rpms/slice-%{nodefamily}
83 # don't overwrite yumgroups.xml if exists
84 %config(noreplace) /var/www/html/install-rpms/slice-%{nodefamily}/yumgroups.xml
85
86 %changelog
87 * Fri Nov 13 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-6
88 - fix for f22 and dnf.conf
89
90 * Fri Jun 26 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-5
91 - the yum config for nodes on f21 and f22
92 - define a new config_file for /etc/dnf/dnf.conf so that /etc/yum.myplc.d
93 - is taken into account on f22
94
95 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-4
96 - minor change; start plc packages only at run-time, not build-time
97 - only available on systems that have systemctl
98
99 * Tue Jul 22 2014 Thomas Dreibholz <dreibh@simula.no> - nodeimage-5.2-4
100 - Post-install fix: trying to start PLC only when it is running, in order to avoid false-positive error message during build.
101
102 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-3
103 - template for f20 yum config
104
105 * Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-2
106 - more timestamps during build
107
108 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-1
109 - add support for f18 yum config
110
111 * Mon Feb 11 2013 Stephen Soltesz <soltesz@opentechinstitute.org> - nodeimage-2.1-4
112
113 * Mon Nov 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-2.1-3
114 - fix /etc/plc.d/packages for empty install dirs
115
116 * Fri Sep 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-2.1-2
117 - exclude slice repos when running plc.d/packages start
118
119 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-2.1-1
120 - renamed as nodeimage - works on both mainline and lxc
121
122 * Thu Feb 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-14
123 - changes needed for build with yumexcludes defined in a separate pkgs file
124
125 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-13
126 - plc.d/packages: rewrote comments about some corner cases where it fails
127 - plc.d/packages: marginally more robust
128
129 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-12
130 - minor tweak in plc.d/packages
131
132 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - bootstrapfs-2.0-11
133 - sl6 templates
134
135 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-10
136 - bugfix for multi-flavour deployments
137
138 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-9
139 - for multi-flavours : 'packages' step in plc.d now handles vserver links and related hacks in yumgroups
140
141 * Thu Jan 27 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-8
142 - no semantic change - attempt to speed up build
143
144 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-7
145 - yum repo template for f14 nodes
146 - tweaks the way /etc/plc.d/packages works
147
148 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootstrapFS-2.0-6
149 - add sha1sum
150 - module name changes
151
152 * Tue Apr 27 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootstrapFS-2.0-5
153 - support different flavours of vservers on nodes
154
155 * Mon Apr 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-4
156 - fix unmatched $ in URL svn keywords
157
158 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-3
159 - choice between various pldistros is not made at build time, but at run time
160 - relies on GetNodeFlavour to expose the node's fcdistro - requires PLCAPI-5.0-5
161 - in addition, the baseurl for the myplc repo is http:// and not https:// anymore
162 - the https method does not work on fedora 12, and GPG is used below anyway
163
164 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-2
165 - new slicerepo package for exposing stuff to slivers
166