Trying to start PLC only when it is running, in order to avoid false-positive error...
[bootstrapfs.git] / slicerepo.spec
1 # build is expected to export the following rpm variables
2 # %{distroname}     : e.g. Fedora
3 # %{distrorelease}  : e.g. 8
4 # %{slice_rpms_plus} : as a +++ separated list of rpms from the build dir
5
6 %define nodefamily %{pldistro}-%{distroname}-%{_arch}
7 %define obsolete_nodefamily %{pldistro}-%{_arch}
8
9 %define name slicerepo-%{nodefamily}
10 %define version 5.2
11 %define taglevel 3
12
13 # pldistro already in the rpm name
14 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
15 %define release %{taglevel}%{?date:.%{date}}
16
17 # we don't really need the standard postinstall process from rpm that
18 # strips files and byte-compiles python files. all files in this
19 # package are comming from other rpm files and they've already went
20 # through this post install processing. - baris
21 %define __os_install_post %{nil}
22
23 Vendor: OneLab
24 Packager: PlanetLab Europe <build@onelab.eu>
25 Distribution: PlanetLab %{plrelease}
26 URL: %{SCMURL}
27
28 Summary: The yum repository for slices, to be installed on the myplc-side
29 Name: %{name}
30 Version: %{version}
31 Release: %{release}
32 License: BSD
33 Group: System Environment/Base
34 Source0: %{name}-%{version}.tar.gz
35 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
36 # other archs must be able to install this
37 BuildArch: noarch
38
39 BuildRequires: rsync 
40 Requires: myplc
41
42 %define debug_package %{nil}
43
44 %description
45 This rpm contains all the rpms that might ship on a sliver image
46 they come organized into a yum repository 
47
48 %prep
49 %setup -q
50
51 %build
52 echo nothing to do at build time for slicerepo
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 repo=slice-%{nodefamily}
58 install -d -m 755 $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo
59 rpms=$(echo %{slice_rpms_plus} | sed -e 's,+++, ,g')
60 for rpm in $rpms; do rsync %{_topdir}/$rpm $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo/ ; done
61 ### yumgroups
62 install -D -m 644 %{_topdir}/RPMS/yumgroups.xml $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo/yumgroups.xml
63 # do not do this yet, as plc.d/packages will do it anyway
64 #createrepo -g yumgroups.xml $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %post
70 if [ ! -e /bin/systemctl ] ; then
71    echo "Systemd is not there. Just starting PLC to handle packages (may fail of PLC is not configured) ..."
72    service plc start packages
73 elif /bin/systemctl status plc >/dev/null ; then
74    echo "Restarting PLC to handle packages ..."
75    service plc restart packages
76 else
77    echo "The PLC is not running. Skipping a restart ..."
78 fi
79
80 %files
81 %defattr(-,root,root,-)
82 /var/www/html/install-rpms/slice-%{nodefamily}
83 # don't overwrite yumgroups.xml if exists
84 %config(noreplace) /var/www/html/install-rpms/slice-%{nodefamily}/yumgroups.xml
85
86 %changelog
87 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-3
88 - template for f20 yum config
89
90 * Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-2
91 - more timestamps during build
92
93 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-1
94 - add support for f18 yum config
95
96 * Mon Feb 11 2013 Stephen Soltesz <soltesz@opentechinstitute.org> - nodeimage-2.1-4
97
98 * Mon Nov 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-2.1-3
99 - fix /etc/plc.d/packages for empty install dirs
100
101 * Fri Sep 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-2.1-2
102 - exclude slice repos when running plc.d/packages start
103
104 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-2.1-1
105 - renamed as nodeimage - works on both mainline and lxc
106
107 * Thu Feb 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-14
108 - changes needed for build with yumexcludes defined in a separate pkgs file
109
110 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-13
111 - plc.d/packages: rewrote comments about some corner cases where it fails
112 - plc.d/packages: marginally more robust
113
114 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-12
115 - minor tweak in plc.d/packages
116
117 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - bootstrapfs-2.0-11
118 - sl6 templates
119
120 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-10
121 - bugfix for multi-flavour deployments
122
123 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-9
124 - for multi-flavours : 'packages' step in plc.d now handles vserver links and related hacks in yumgroups
125
126 * Thu Jan 27 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-8
127 - no semantic change - attempt to speed up build
128
129 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-7
130 - yum repo template for f14 nodes
131 - tweaks the way /etc/plc.d/packages works
132
133 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootstrapFS-2.0-6
134 - add sha1sum
135 - module name changes
136
137 * Tue Apr 27 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - BootstrapFS-2.0-5
138 - support different flavours of vservers on nodes
139
140 * Mon Apr 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-4
141 - fix unmatched $ in URL svn keywords
142
143 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-3
144 - choice between various pldistros is not made at build time, but at run time
145 - relies on GetNodeFlavour to expose the node's fcdistro - requires PLCAPI-5.0-5
146 - in addition, the baseurl for the myplc repo is http:// and not https:// anymore
147 - the https method does not work on fedora 12, and GPG is used below anyway
148
149 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-2.0-2
150 - new slicerepo package for exposing stuff to slivers
151