naming .lst files after pldistro - including the <pldistro>-filesystems directory
[bootstrapfs.git] / bootstrapfs.spec
index 51c084b..0283ee0 100644 (file)
@@ -31,7 +31,7 @@ BootManager to instantiate a node with a new filesystem.
 
 %build
 pushd BootstrapFS
-./build.sh
+./build.sh %{pldistro}
 popd BootstrapFS
 
 %install
@@ -44,7 +44,7 @@ install -D -m 644 PlanetLab-Bootstrap.tar.bz2 \
 
 for bootstrapfs in $(ls bootstrap-filesystems/*.lst) ; do 
        NAME=$(basename $bootstrapfs .lst)
-       install -D -m 644 bootstrap-filesystems/PlanetLab-Bootstrap-${NAME}.tar.bz2 \
+       install -D -m 644 %{pldistro}-filesystems/PlanetLab-Bootstrap-${NAME}.tar.bz2 \
                $RPM_BUILD_ROOT/var/www/html/boot/PlanetLab-Bootstrap-${NAME}.tar.bz2
 done