Second step towards multiarch myplc https://svn.planet-lab.org/ticket/214
[bootstrapfs.git] / bootstrapfs.spec
index 5f9ad58..4efaea9 100644 (file)
@@ -1,11 +1,18 @@
+#
+# $Id$
+#
+%define url $URL$
+
 %define name bootstrapfs
 %define version 0.1
-%define release 0%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+%define taglevel 2
+
+%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
 Vendor: PlanetLab
 Packager: PlanetLab Central <support@planet-lab.org>
-Distribution: PlanetLab 4.2
-URL: http://svn.planet-lab.org/svn/BootStrapFS/
+Distribution: PlanetLab %{plrelease}
+URL: %(echo %{url} | cut -d ' ' -f 2)
 
 Summary: The PlanetLab Bootstrap Filesystems
 Name: %{name}
@@ -15,6 +22,8 @@ License: BSD
 Group: System Environment/Base
 Source0: %{name}-%{version}.tar.gz
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
+# other archs must be able to install this
+BuildArch: noarch
 
 Requires: tar, gnupg, sharutils, bzip2
 
@@ -31,21 +40,22 @@ BootManager to instantiate a node with a new filesystem.
 
 %build
 pushd BootstrapFS
-./build.sh
+./build.sh %{pldistro} 
 popd BootstrapFS
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
 pushd BootstrapFS
+arch=$(uname -i)
 
-install -D -m 644 PlanetLab-Bootstrap.tar.bz2 \
-       $RPM_BUILD_ROOT/var/www/html/boot/PlanetLab-Bootstrap.tar.bz2
+install -D -m 644 bootstrapfs-%{pldistro}-${arch}.tar.bz2 \
+       $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-%{pldistro}-${arch}.tar.bz2
 
-for bootstrapfs in $(ls bootstrap-filesystems/*.lst) ; do 
-       NAME=$(basename $bootstrapfs .lst)
-       install -D -m 644 bootstrap-filesystems/PlanetLab-Bootstrap-${NAME}.tar.bz2 \
-               $RPM_BUILD_ROOT/var/www/html/boot/PlanetLab-Bootstrap-${NAME}.tar.bz2
+for pkgs in $(ls ../build/config.%{pldistro}/bootstrapfs-*.pkgs) ; do 
+    NAME=$(basename $pkgs .pkgs | sed -e s,bootstrapfs-,,)
+    install -D -m 644 %{pldistro}-filesystems/bootstrapfs-${NAME}-${arch}.tar.bz2 \
+               $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-${NAME}-${arch}.tar.bz2 
 done
 
 popd
@@ -66,12 +76,15 @@ fi
 
 %post
 
-
 %files
 %defattr(-,root,root,-)
-%{_datadir}/%{name}
-/var/www/html/boot/PlanetLab-Bootstrap*.tar.bz2
+/var/www/html/boot/bootstrapfs*.tar.bz2
 
 %changelog
+* Fri Jan 18 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-0.1-1 bootstrapfs-0.1-2
+- search more carefully for alternate pkgs files
+- handling of sysconfig/crontab and creation of site_admin reviewed
+- (this tag is set with module-tag.py)
+
 * Fri Sep  2 2005 Mark Huang <mlhuang@cotton.CS.Princeton.EDU> - 
 - Initial build.