the new bootstrapfs-*-plain rpm has uncompressed bootstrapfs images (for tests)
[bootstrapfs.git] / bootstrapfs.spec
index f339419..650ca05 100644 (file)
@@ -39,6 +39,12 @@ AutoReqProv: no
 The PlanetLab Bootstrap Filesystem(s) are downloaded by the
 BootManager to instantiate a node with a new filesystem.
 
+%package plain
+Summary: The (uncompressed) PlanetLab Bootstrap Filesystems for %{nodefamily}
+Group: System Environment/Base
+%description plain
+This package provides the same functions as %{name} but with uncompressed tarball for faster tests.
+
 %prep
 %setup -q
 
@@ -55,11 +61,15 @@ arch=$(uname -i)
 
 install -D -m 644 bootstrapfs-%{pldistro}-${arch}.tar.bz2 \
        $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-%{pldistro}-${arch}.tar.bz2
+install -D -m 644 bootstrapfs-%{pldistro}-${arch}.tar \
+       $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-%{pldistro}-${arch}.tar
 
 for pkgs in $(ls ../build/config.%{pldistro}/bootstrapfs-*.pkgs) ; do 
     NAME=$(basename $pkgs .pkgs | sed -e s,bootstrapfs-,,)
     install -D -m 644 %{pldistro}-filesystems/bootstrapfs-${NAME}-${arch}.tar.bz2 \
                $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-${NAME}-${arch}.tar.bz2 
+    install -D -m 644 %{pldistro}-filesystems/bootstrapfs-${NAME}-${arch}.tar \
+               $RPM_BUILD_ROOT/var/www/html/boot/bootstrapfs-${NAME}-${arch}.tar 
 done
 
 popd
@@ -84,6 +94,10 @@ fi
 %defattr(-,root,root,-)
 /var/www/html/boot/bootstrapfs*.tar.bz2
 
+%files plain
+%defattr(-,root,root,-)
+/var/www/html/boot/bootstrapfs*.tar
+
 %changelog
 * Fri Nov 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-4
 - cosmetic changes in build: displays duration, and shows up in summary