conf_files belong to the same module
[bootstrapfs.git] / bootstrapfs.spec
index 90d07d3..e64fb7a 100644 (file)
@@ -65,19 +65,16 @@ Requires: httpd
 %build
 pushd BootstrapFS
 ./build.sh %{pldistro} 
-popd BootstrapFS
+popd
 
 # xxx in a multi-flavour myplc, we should ship for all fcdistros
 # and let the php scripts do the right thing
 
 pushd BootstrapFS/nodeconfig/yum
-
-# expand list of kexcludes
-
 # scan fcdistros and catenate all repos in 'stock.repo' so db-config can be distro-independant
-
 for fcdistro in $(ls); do
     [ -d $fcdistro ] || continue
+    # get kexcludes for that distro
     KEXCLUDE="exclude=$(../../../build/getkexcludes.sh -f $fcdistro)"
     pushd $fcdistro/yum.myplc.d
     echo "* Handling KEXCLUDE in yum repo for $fcdistro ($KEXCLUDE)"
@@ -89,7 +86,6 @@ for fcdistro in $(ls); do
     cat *.repo > stock.repo
     popd
 done
-
 popd
 
 %install
@@ -122,6 +118,13 @@ install -D -m 644 ./yum/%{distroname}/yum.conf                  $RPM_BUILD_ROOT/var/www/htm
 install -D -m 644 ./yum/%{distroname}/yum.myplc.d/stock.repo $RPM_BUILD_ROOT/var/www/html/yum/stock.repo
 popd
 
+pushd BootstrapFS
+echo "* Installing db-config.d files"
+mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
+cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
+chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
+popd
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -143,6 +146,7 @@ chmod 700 /var/log/bm
 %files -n nodeyum
 %defattr(-,root,root,-)
 /var/www/html/yum
+/etc/planetlab/db-config.d
 
 %changelog
 * Mon Jan 04 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - BootstrapFS-1.0-11