eradicate svn keywords
[bootstrapfs.git] / bootstrapfs.spec
index 083edf1..f9d0fcd 100644 (file)
@@ -5,7 +5,7 @@
 
 %define name bootstrapfs-%{nodefamily}
 %define version 2.0
-%define taglevel 13
+%define taglevel 14
 
 # pldistro already in the rpm name
 #%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
@@ -85,7 +85,7 @@ pushd bootstrapfs/nodeconfig/yum
 for fcdistro in $(ls); do
     [ -d $fcdistro ] || continue
     # get packages to exclude on nodes for that fcdistro/pldistro
-    NODEYUMEXCLUDE="exclude=$(../../../build/nodeyumexclude.sh $fcdistro $pldistro)"
+    NODEYUMEXCLUDE="exclude=$(../../../build/nodeyumexclude.sh $fcdistro %{pldistro})"
     pushd $fcdistro/yum.myplc.d
     echo "* Handling NODEYUMEXCLUDE in yum repo for $fcdistro/$pldistro ($NODEYUMEXCLUDE)"
     for filein in $(find . -name '*.in') ; do
@@ -152,6 +152,9 @@ rm -rf $RPM_BUILD_ROOT
 /etc/plc.d
 
 %changelog
+* Thu Feb 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-14
+- changes needed for build with yumexcludes defined in a separate pkgs file
+
 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - bootstrapfs-2.0-13
 - plc.d/packages: rewrote comments about some corner cases where it fails
 - plc.d/packages: marginally more robust