no more unversioned obsolete
[bootstrapfs.git] / nodeimage.spec
index d692dbe..3a11bf2 100644 (file)
@@ -6,7 +6,6 @@
 %define taglevel 9
 
 # pldistro already in the rpm name
-#%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 %define release %{taglevel}%{?date:.%{date}}
 
 # we don't really need the standard postinstall process from rpm that
@@ -31,7 +30,14 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 # other archs must be able to install this
 BuildArch: noarch
 
-Requires: tar, gnupg, sharutils, bzip2
+Requires: tar, sharutils, bzip2
+# see myplc/plc.d/gpg for more details on the gnupg / gpg topic
+%if "%{distro}" == "Fedora" && %{distrorelease} >= 31
+Requires: gnupg1
+%else
+Requires: gnupg
+%endif
+
 # this is for plc.d/packages that uses ed for hacking yumgroups.xml
 Requires: ed
 
@@ -39,7 +45,7 @@ Requires: ed
 Obsoletes: bootstrapfs-%{nodefamily}
 # 5.0 now has 3-fold nodefamily
 %define obsolete_nodefamily %{pldistro}-%{_arch}
-Obsoletes: bootstrapfs-%{obsolete_nodefamily}
+# Obsoletes: bootstrapfs-{obsolete_nodefamily}
 
 AutoReqProv: no
 %define debug_package %{nil}