and again
[bootstrapfs.git] / nodeimage.spec
index d0ba41d..da01e7d 100644 (file)
@@ -3,10 +3,9 @@
 
 %define name nodeimage-%{nodefamily}
 %define version 5.2
-%define taglevel 4
+%define taglevel 9
 
 # pldistro already in the rpm name
-#%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 %define release %{taglevel}%{?date:.%{date}}
 
 # we don't really need the standard postinstall process from rpm that
@@ -31,7 +30,14 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 # other archs must be able to install this
 BuildArch: noarch
 
-Requires: tar, gnupg, sharutils, bzip2
+Requires: tar, sharutils, bzip2
+# see myplc/plc.d/gpg for more details on the gnupg / gpg topic
+%if "%{distro}" == "Fedora" && %{distrorelease} >= 31
+Requires: gnupg1
+%else
+Requires: gnupg
+%endif
+
 # this is for plc.d/packages that uses ed for hacking yumgroups.xml
 Requires: ed
 
@@ -39,7 +45,7 @@ Requires: ed
 Obsoletes: bootstrapfs-%{nodefamily}
 # 5.0 now has 3-fold nodefamily
 %define obsolete_nodefamily %{pldistro}-%{_arch}
-Obsoletes: bootstrapfs-%{obsolete_nodefamily}
+# Obsoletes: bootstrapfs-{obsolete_nodefamily}
 
 AutoReqProv: no
 %define debug_package %{nil}
@@ -71,10 +77,10 @@ for the MyPLC side.
 pushd nodeimage
 ./build.sh %{pldistro} 
 for tar in *.tar *.tar.bz2; do 
-    start=$(date +%H-%M-%S)
+    start=$(date --iso-8601=seconds)
     sha1sum $tar > $tar.sha1sum
     chmod 444 $tar.sha1sum
-    end=$(date +%H-%M-%S)
+    end=$(date --iso-8601=seconds)
     echo "* Computed SHA1 checksum for $tar ($start .. $end) "
 done
 popd
@@ -99,7 +105,7 @@ for fcdistro in $(ls); do
 done
 popd
 
-echo "* nodeconfig/yum done $(date +%H-%M-%S)"
+echo "* nodeconfig/yum done $(date --iso-8601=seconds)"
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -155,6 +161,25 @@ rm -rf $RPM_BUILD_ROOT
 /etc/plc.d
 
 %changelog
+* Mon Jan 07 2019 Thierry <Parmentelat> - nodeimage-5.2-9
+- ok for f27 and f29
+- cleanup old distros
+
+* Sun Jul 16 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-8
+- fix the fedora and fedora-updates repo definitions for f25
+- add /etc/plc.d/packages index
+
+* Sun Jul 10 2016 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-7
+- yum config ; deprecates old fedora releases, add support for f23/f24
+
+* Fri Nov 13 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-6
+- fix for f22 and dnf.conf
+
+* Fri Jun 26 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-5
+- the yum config for nodes on f21 and f22
+- define a new config_file for /etc/dnf/dnf.conf so that /etc/yum.myplc.d
+- is taken into account on f22
+
 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeimage-5.2-4
 - minor change; start plc packages only at run-time, not build-time
 - only available on systems that have systemctl