and again
[bootstrapfs.git] / nodeimage.spec
index d692dbe..da01e7d 100644 (file)
@@ -6,7 +6,6 @@
 %define taglevel 9
 
 # pldistro already in the rpm name
 %define taglevel 9
 
 # pldistro already in the rpm name
-#%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 %define release %{taglevel}%{?date:.%{date}}
 
 # we don't really need the standard postinstall process from rpm that
 %define release %{taglevel}%{?date:.%{date}}
 
 # we don't really need the standard postinstall process from rpm that
@@ -31,7 +30,14 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 # other archs must be able to install this
 BuildArch: noarch
 
 # other archs must be able to install this
 BuildArch: noarch
 
-Requires: tar, gnupg, sharutils, bzip2
+Requires: tar, sharutils, bzip2
+# see myplc/plc.d/gpg for more details on the gnupg / gpg topic
+%if "%{distro}" == "Fedora" && %{distrorelease} >= 31
+Requires: gnupg1
+%else
+Requires: gnupg
+%endif
+
 # this is for plc.d/packages that uses ed for hacking yumgroups.xml
 Requires: ed
 
 # this is for plc.d/packages that uses ed for hacking yumgroups.xml
 Requires: ed
 
@@ -39,7 +45,7 @@ Requires: ed
 Obsoletes: bootstrapfs-%{nodefamily}
 # 5.0 now has 3-fold nodefamily
 %define obsolete_nodefamily %{pldistro}-%{_arch}
 Obsoletes: bootstrapfs-%{nodefamily}
 # 5.0 now has 3-fold nodefamily
 %define obsolete_nodefamily %{pldistro}-%{_arch}
-Obsoletes: bootstrapfs-%{obsolete_nodefamily}
+# Obsoletes: bootstrapfs-{obsolete_nodefamily}
 
 AutoReqProv: no
 %define debug_package %{nil}
 
 AutoReqProv: no
 %define debug_package %{nil}
@@ -71,10 +77,10 @@ for the MyPLC side.
 pushd nodeimage
 ./build.sh %{pldistro} 
 for tar in *.tar *.tar.bz2; do 
 pushd nodeimage
 ./build.sh %{pldistro} 
 for tar in *.tar *.tar.bz2; do 
-    start=$(date +%H-%M-%S)
+    start=$(date --iso-8601=seconds)
     sha1sum $tar > $tar.sha1sum
     chmod 444 $tar.sha1sum
     sha1sum $tar > $tar.sha1sum
     chmod 444 $tar.sha1sum
-    end=$(date +%H-%M-%S)
+    end=$(date --iso-8601=seconds)
     echo "* Computed SHA1 checksum for $tar ($start .. $end) "
 done
 popd
     echo "* Computed SHA1 checksum for $tar ($start .. $end) "
 done
 popd
@@ -99,7 +105,7 @@ for fcdistro in $(ls); do
 done
 popd
 
 done
 popd
 
-echo "* nodeconfig/yum done $(date +%H-%M-%S)"
+echo "* nodeconfig/yum done $(date --iso-8601=seconds)"
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %install
 rm -rf $RPM_BUILD_ROOT