let plc.d/packages redo createrepo
[bootstrapfs.git] / noderepo.spec
index 1b11582..8e5ae3d 100644 (file)
@@ -8,9 +8,11 @@
 # %{distrorelease}  : e.g. 8
 # %{node_rpms_plus} : as a +++ separated list of rpms from the build dir
 
-%define name noderepo-%{distroname}-%{_arch}
-%define version 4.2
-%define taglevel 1
+%define nodetype %{pldistro}%{distroname}%{_arch}
+
+%define name noderepo-%{nodetype}
+%define version 0.1
+%define taglevel 2
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -28,7 +30,8 @@ Group: System Environment/Base
 Source0: %{name}-%{version}.tar.gz
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 
-BuildRequires: rsync createrepo
+BuildRequires: rsync 
+Requires: myplc
 
 %define debug_package %{nil}
 
@@ -45,23 +48,24 @@ echo nothing to do at build time for noderepo
 %install
 rm -rf $RPM_BUILD_ROOT
 
-repo=planetlab-%{distroname}-%{_arch}
+repo=%{nodetype}
 install -d -m 755 $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo
-rpms=$(echo %{node_rpms_plus} | sed -e s,+++, ,g)
-for rpm in $rpms; do rsync $RPM_BUILD_ROOT/$rpm $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo/ ; done
+rpms=$(echo %{node_rpms_plus} | sed -e 's,+++, ,g')
+for rpm in $rpms; do rsync %{_topdir}/$rpm $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo/ ; done
 ### yumgroups
-install -D -m 644 $RPM_BUILD_ROOT/RPMS/yumgroups.xml $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo
-createrepo -g yumgroups.xml $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo
+install -D -m 644 %{_topdir}/RPMS/yumgroups.xml $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo
+# do not do this yet, as plc.d/packages will do it anyway
+#createrepo -g yumgroups.xml $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
-
+service plc start packages
 
 %files
 %defattr(-,root,root,-)
-/var/www/html/install-rpms/planetlab-%{distroname}-%{_arch}
+/var/www/html/install-rpms/%{nodetype}
 
 %changelog
 * Tue Mar 4 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> -