missing quotes
[bootstrapfs.git] / noderepo.spec
index 60e5dd4..ab19bba 100644 (file)
@@ -8,7 +8,7 @@
 # %{distrorelease}  : e.g. 8
 # %{node_rpms_plus} : as a +++ separated list of rpms from the build dir
 
-%define name noderepo-%{distrovsname}-%{_arch}
+%define name noderepo-%{distroname}-%{_arch}
 %define version 4.2
 %define taglevel 1
 
@@ -45,15 +45,13 @@ echo nothing to do at build time for noderepo
 %install
 rm -rf $RPM_BUILD_ROOT
 
-pushd BootstrapFS
-repo=planetlab-%{distrovsname}-%{_arch}
+repo=planetlab-%{distroname}-%{_arch}
 install -d -m 755 $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo
-rpms=$(echo %{node_rpms_plus} | sed -e s,+++, ,g)
+rpms=$(echo %{node_rpms_plus} | sed -e 's,+++, ,g')
 for rpm in $rpms; do rsync $RPM_BUILD_ROOT/$rpm $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo/ ; done
 ### yumgroups
 install -D -m 644 $RPM_BUILD_ROOT/RPMS/yumgroups.xml $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo
 createrepo -g yumgroups.xml $RPM_BUILD_ROOT/var/www/html/install-rpms/$repo
-popd
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -63,7 +61,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(-,root,root,-)
-/var/www/html/install-rpms/planetlab-%{distrovsname}-%{_arch}
+/var/www/html/install-rpms/planetlab-%{distroname}-%{_arch}
 
 %changelog
 * Tue Mar 4 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> -