Trying to start PLC only when it is running, in order to avoid false-positive error...
[bootstrapfs.git] / slicerepo.spec
index 86e3cdd..5f24b5a 100644 (file)
@@ -67,7 +67,15 @@ install -D -m 644 %{_topdir}/RPMS/yumgroups.xml $RPM_BUILD_ROOT/var/www/html/ins
 rm -rf $RPM_BUILD_ROOT
 
 %post
-service plc start packages
+if [ ! -e /bin/systemctl ] ; then
+   echo "Systemd is not there. Just starting PLC to handle packages (may fail of PLC is not configured) ..."
+   service plc start packages
+elif /bin/systemctl status plc >/dev/null ; then
+   echo "Restarting PLC to handle packages ..."
+   service plc restart packages
+else
+   echo "The PLC is not running. Skipping a restart ..."
+fi
 
 %files
 %defattr(-,root,root,-)